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1: SUMMARY 

QGIS is an open-source GIS program for the display and analysis of GIS data. It  has developed 

significantly in the past few years and is now a valuable tool for the mineral exploration industry , 

and a viable alternative to the commercially available GIS packages. Although not specifically 

written for geological applications, QGIS can do most of the required GIS tasks required by today’s 

geoscientists. The terminology is different to the usual earth sciences programs, but many QGIS 

algorithms do the same thing but with a different name.  

This manual examines QGIS and how QGIS can assist geoscientists in undertake mapping and 

geoscientific tasks in their day-to-day work. The manual has evolved during several years teaching 

QGIS to geoscientists in Australia and has been produced to offer a go-to document for earth 

science related GIS activities. 

Accessing data from the internet via web map and web feature servers is illustrated to show how 

using this data can help with compiling available data for an area. Detailed aerial photography and 

Google Earth can be easily integrated with mapping data to allow the creation of accurate base 

maps for a variety of geological applications. A wide range of vector and raster (grid and image) 

data formats can be easily imported into QGIS, including GPS gpx files.  

The presentation options for point, line and polygon data are extensive and easily customised. A 

variety of geological symbols and pattern fills can be applied to points, lines , and polygons. 

Geochemical and geophysical data can also be presented in a variety of display options. Basic 

3D display of map data is also available via the QGIS2threejs plug-in and the QGIS 3D view. 

QGIS has many plug-ins for specialised tasks and the semi-automatic classification plug-in (SCP), 

is one example of where users can select, download, and process ASTER, Landsat, and Sentinel 

2 satellite data. It is recommended that new users peruse the plugins list to see what plugins are 

available and for those that may be of use in their work. 

Map production is easy in QGIS with the “Print Layout” allowing extensive options for the display 

and printing of maps. 

This document is a working draft and in continuous development. There may be errors and 

omissions, and these will be rectified as time permits. This manual applies to version 3.28. Please 

feel free to share this document and please contact me if you find any errors. 

 

2: INTRODUCTION 

This document is aimed at the exploration geologist, but the techniques outlined are easily 

transferrable to other areas. The author has been using QGIS since 2015 and the version used in 

this document is version 3.28. 

The reader is encouraged to join the international online QGIS user forum at 

http://lists.osgeo.org/mailman/listinfo/qgis-user.  

This document will not go into the detail that is covered by the official QGIS User Guide and 

Training Manuals (https://docs.qgis.org/testing/pdf/en/) and other reference books (e.g. Graser 

2016) on QGIS on topics like editing etc., but will discuss those tools used particularly in geological 

mapping, mineral exploration and remote sensing. See this video for an explanation of some of 

the advanced editing functions - https://youtu.be/jZYKGrIyVCA.  

The author has been using QGIS since 2015 after about 20 years using the MapInfo -Discover 

software. He has been involved in exploration and mining geology for over 40 years, with almost 

http://lists.osgeo.org/mailman/listinfo/qgis-user
https://docs.qgis.org/testing/pdf/en/
https://youtu.be/jZYKGrIyVCA
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20 years with CRA Exploration Pty Limited, Argyle Diamonds and Rio Tinto Exploration from 1979 

till 1997. The past 20 years (1998 – present) has been engaged in consulting roles to the diamond 

exploration and mining industry with activities in Australia, Brazil, China, Greenland and India, and 

exploration for other commodities including base metals, iron ore, and manganese.  

3: ABOUT QGIS 

QGIS is a user-friendly open-source Geographic Information System (GIS) licensed under the 

GNU General Public License and is an official project of the Open Source Geospatial Foundation 

(OSGeo). It runs on Linux, Unix, Mac OSX, Windows and Android and supports numerous vector, 

raster, and database formats. 

The Open Geospatial Consortium (OGC) is an international consortium of more than 530 

businesses, government agencies, research organizations, and universities driven to make 

geospatial (location) information and services FAIR - Findable, Accessible, Interoperable, and 

Reusable. OGC’s members create free geospatial standards. OGC also actively analyses 

emerging tech trends, and runs an agile, collaborative Research and Development (R&D) lab that 

builds and tests innovative solutions to members' use cases.  

For more information visit “ogc.org”. 

For those users requiring a “gentle” introduction to GIS, please see this link 

https://docs.qgis.org/3.4/en/docs/gentle_gis_introduction/. 

QGIS is a volunteer driven project. They welcome contributions in the form of code contributions, 

bug fixes, bug reports, contributed documentation, advocacy and supporting other users on their 

mailing lists and gis.stackexchange.com. If you are interested in actively supporting the project, 

you can find more information under the development menu and on the QGIS Wiki. If you find 

QGIS valuable in your workplace, please donate to the QGIS project – the details are on the 

website. 

QGIS provides a continuously growing number of capabilities provided by core functions and 

plugins. 

This document will mainly address workflows for geoscientists but there are many other tools 

available in QGIS and worthy of some exploration of their functions. Currently QGIS does not have 

a detailed downhole or cross section display option, but there are groups across the world that 

are crowd sourcing the development of the drill hole and cross section plug-in. The existing 

Geoscience plugin does display drill holes in plan and in cross section but is limited in its features. 

QGIS does not also handle all the various geophysical processing options, and again there is 

interest from various groups to develop plug-ins for geophysical processing. 

A good explanation of QGIS and where it came from can be found here 

https://www.youtube.com/watch?v=As4hfPecxoU.  

If you find QGIS makes a valuable contribution to your business, please consider making a 

donation to assist with continual code improvements – see this link 

https://qgis.org/en/site/getinvolved/donations.html. 

Installation options are available on QGIS download page 

(https://qgis.org/en/site/forusers/download.html) with options to download either the development 

version (via OS4Geo) or the standalone installers (recommended). 

The original default file format for QGIS was the ESRI shape file (*.shp) and this format has been 

around for many years and can be read by many software products. It is an old format and has 

limitations, e.g. field names are limited to 10 characters. QGIS has adopted the new “Geopackage” 

https://docs.qgis.org/3.4/en/docs/gentle_gis_introduction/
https://www.youtube.com/watch?v=As4hfPecxoU
https://qgis.org/en/site/getinvolved/donations.html
https://qgis.org/en/site/forusers/download.html
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file format as its default spatial file format. Geopackage files can contain different types of vector 

geometry – points, lines and polygons – and can also include raster images. Geopackage files 

can be up to 140 TB in size! Layers can be imported into an existing Geopackage by dragging 

from the Layer panel onto the Geopackage name in the Browser panel. Styling information can 

also be saved into the Geopackage file. When digitising into a Geopackage file, each new feature 

is auto numbered. Raster images imported into a Geopackage appear to be significantly 

compressed when compared with a GeoTIFF without any major loss of quality. ESRI and recent 

MapInfo products can read Geopackage files. 

Shape files have a number of limitations such as field/attribute column names are limited to 10 

characters, it lacks a time data type, only supports text fields to 255 characters in length and is 

limited to 2 GB in size. 

GeoPackage files on the other hand allows point, line vector and raster files to be stored in the 

one file. Formats/styles can be saved into the Geopackage file and it can be up to 140 TB in size.  

When adding features during digitising, for example, a Geopackage file will automatically populate 

the id field with sequential numbers. See this web link for further information 

https://carto.com/blog/fgdb-gpkg/. Note that Geopackage files are single user only and if you need 

multiple user access at the same time then PostgreSQL and PostGIS may be required. 

 

4: INSTALLING QGIS 

 

4.1 PC Installation 

 

The QGIS program can be downloaded from the QGIS Project website http://www.qgis.org/en/site/ 

and a choice can be made between various 64 bit versions of the recent release and long term 

release versions. The Standalone Installers will install the program into the Program Files 

directory. 

The OSGeo4W (Open source geospatial for Windows) option can be also be used and this option 

places a small executable file on your PC which can be run when desired to update to the latest 

versions of the LTR and development versions. This version installs the software into the root 

directory of your PC (e.g. C:\OSGeo4W64). For first-time Windows users, it is recommended to 

install the “Download for Windows” option. 

 

 

 

 

https://carto.com/blog/fgdb-gpkg/
http://www.qgis.org/en/site/
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The installer (“Download QGIS 3.28”) will install the program into the program files folder and 

create a folder on your desktop with shortcuts to the run the program. I t is recommended to run 

the “QGIS Desktop 3.x with GRASS 7.x.x” version which runs the GIS program and associated 

GRASS GIS functions.  

When you run the OSGeo4W Network Installer option you will see the following screen shot. For 

a first-time installation, choose the “Express Desktop Install” which will install the basic programs 

and required utility files. 
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After the initial “Express Desktop Install”, this window will be different and you can then check for 

updates by running the “osgeo4w-setup.exe” file again (usually located in the Downloads folder) 

where you can then select “Advanced Install” and select which products you wish to update. The 

OSGeo4W option can be used instead of the Standalone Installer option. 
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The select packages window (above) indicates there is an update for v 3.9.0-12 to v 3.9.0-15 in 

the QGIS development version (old versions by way of illustration only!). 

User manual and training documents can be viewed, or pdf versions downloaded from the QGIS 

web site (https://qgis.org/en/docs/index.html). 

 

 

The QGIS desktop is similar to other GIS applications with menu items along the top and numerous 

buttons/icons to make it easier to select various options without having to navigate menus. All the 

menu items and panels are customisable to user preferences. QGIS has operations to import 

vector and raster data from a variety of formats into QGIS, with excellent editing and analysis tools  

from the integration of other GIS systems such as GRASS and SAGA. Some of these tools are 

illustrated in the right-hand panel of the figure above. 

If you need to reset the QGIS window and/or panel locations, go to Settings > Options > System 

tab, select the Reset button (right hand side of screen) and re-start QGIS. 

The appearance of the desktop can also be changed by using the Settings > Options > Gene ral 

tab and in the Application section find the “UI Theme” where the appearance of the desktop can 

be modified. A recent addition here is the “Blend of Grey” option.  

4.2 Mac Installation 

 

Installation on a Mac is different than for a PC and it is recommended to download and install 

QGIS from the QGIS download window. 

Install the LTR or the Latest Release version. 

 

 

https://qgis.org/en/docs/index.html
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To install the custom (geological) SVG files on a Mac, in QGIS, go to Settings > Options > System 

tab and look for the location of the svg files – something like 

/Applications/QGIS3.app/Contents/MacOS/../Resources/svg/. Use the Finder to navigate to the 

Applications folder, then right click on the QGIS program icon, select “Show Package Contents”, 

open the “Contents” folder and the “Resources” folder. Put the custom (geological) SVG folders 

into the SVG folder. 
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5: PLUG-INS 

Plug-ins are small utility programs that greatly expand the capabilities of QGIS. There are currently 

over 1100 plug-ins available for download. These plug-ins are all free and have usually been 

written to solve a specific problem or task for users. It is recommended that users peruse the 

plugins list to see what plugins might be applicable to their workflow. 

Eleven plug-ins are installed by default in version 3.28 as are listed below. 

DB Manager 
Geometry Checker 
GRASS7 
GRASS GIS provider 
MetaSearch Catalog Client 
Offline Editing 
OrfeoToolbox provider 
Processing 
SAGA GIS provider 
Topology Checker 
 

To use these pre-installed plug-ins, you may need to “enable” them in the Plug-Ins > Manage and 

Install Plug-Ins > Installed window. Enable the plug-in by selecting the check box next to the plug-

in. 

 

Additional plug-ins that are recommended are as follows; 

Data Plotly (graphing of data) 
Geoscience (for plotting drill holes on plans and sections 
QuickMapServices (add additional services under the extra services option) 
QGIS2Threejs (3D viewer) 
Semi-Automatic Classification (satellite data selection and processing)  
Shape Tools (creation of numerous types of vector objects) 
Spreadsheet Layers (used to import Excel spreadsheets) 
SRTM Downloader (for accessing SRTM elevation data)  
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If the QGIS start-up is being significantly delayed during start-up (saying “Loading Plugins”) then 

they can be temporarily disabled by going to the Plug-in Manager and un-tick those that not 

needed or infrequently used. They can be turned on when needed. 

In the Plug-Ins > Settings page, check the “Check for updates on start-up” and “Show also 

experimental plugins”. This will then alert the user to updates of existing plug-ins and the release 

of new plug-ins whenever QGIS is started. Note that when you first open the Plugins manager, 

you may see a “New” tab to show you what new plugins have been released since you last opened 

the Plug-in Manager. If you are working off-line with no internet, turn-off the “check for updates on 

start-up” to skip the web search and update function. 

 

 

Some managed IT systems block the loading of the Plug-in’s repository data. If this happens, try 

selecting the Settings > Options > Network, and check the “use proxy server”. Try again to 

download the repository. If this loads the repositories, then uncheck this box and try again to install 

the plugins. 

Network managers may also restrict the installation of plugins. If you have problems, contact your 

network manager. 
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6: ACCESSING DATA OVER THE WEB 

Many government and private corporations have made available datasets for use in GIS programs. 

There may be usage restrictions and the conditions of use should be checked at the data source. 

The amount of free data on the web is truly amazing and users are encouraged to explore the web 

for data. 

QGIS has many options to access on-line web datasets. These can be in the form of a WFS (web 

feature service – vector data), WMS (web map service – raster data) or as a WMTS (web map tile 

server – tiled raster data, e.g. Google Earth). Australian data can be searched at “data.gov.au” 

and Western Australian data is available at “data.wa.gov.au”. 

Satellite data for the ASTER, Landsat, MODIS and Sentinel missions can be downloaded and 

processed via the Semi-Automatic Classification plug-in in QGIS or via the USGS EarthExplorer 

portal and this is discussed below. Remote sensing satellite data (including Hyperion multispectral 

scanner and radar data) can also be downloaded via the USGS EarthExplorer and ESA (European 

Space Agency) websites. 

6.1 Australian Data Sets 

The Australian government has the “National Map” portal (https://nationalmap.gov.au) where data 

can be accessed for Australia-wide data sets or from the individual states and territories.  The WA 

DMIRS (WA mines dept) data can also be accessed via this portal.  
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6.2 Geological Survey of Western Australia 

The Department of Mines, Industry Regulation and Safety (DMIRS, http://www.dmirs.wa.gov.au/) 

is home to the Geological Survey of Western Australia (GSWA). This site contains many data sets, 

most of which can be downloaded from the “Software and Data Centre” 

(https://dasc.dmirs.wa.gov.au/dasc/).  

Registered raster files of the 100k and 250k geological map sheets have been mosaiced into 1:1 

million map sheet areas and are in jp2 (jpeg2000) format registered in GDA94 MGA grid 

coordinates. The “jp2” format contains the projection and registration data embedded in the file. 

Raster files of individual map sheets in either GDA94 lat/long or MGA can also be downloaded 

from the data centre. 

Always check that QGIS is using the current coordinate reference system when it loads these files  

– GDA94 lat/log has EPSG 4283, GDA94 UTM zone xx is EPSG 283xx. 

The digital vector files for the 250k and 100k geology sheets vary in their data content depending 

upon the age of the map sheet edition. The GSWA use ArcView for their GIS system and many of 

their datasets contain “lyr” style and GeoMap “gmp” files. It has been requested that the data 

supplied by the GSWA also contain the colour and pattern information to allow users of other GIS 

systems (like QGIS) to style their maps like the GSWA style. North Road Consulting (https://north-

road.com/slyr/) have developed a plugin to convert “lyr” style files to QGIS style files and assits 

QGIS users to style their maps in a similar fashion to the Arc GSWA maps.  Some of the recent 

regional geology releases by the GSWA do have *.qlr files which are QGIS layer definition files.  

6.3 Landgate and Open Data WA 

The WA government has made available a large variety of GIS datasets through their Open Data 

portal (data.wa.gov.au). Data from other states can be accessed in a similar manner. Searches 

can be made on this site and both vector data and web service links are supplied.  More detailed 

datasets are available for WA from Landgate, but they may require a subscription. Many 

datasets are however free, and registration is no longer required for the free datasets. 

Links to some of the WA web services are as follows; 

Web Map Server Links 

Public: 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning/Ma

pServer/WMSServer 

Imagery: 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Locate/MapServer/WMSSe

rver 

Web Feature Server Links 

Maps 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning_W

FS/MapServer/WFSServer 

Imagery 

http://www.dmirs.wa.gov.au/
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Locate/MapServer/WMSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Locate/MapServer/WMSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning_WFS/MapServer/WFSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Property_and_Planning_WFS/MapServer/WFSServer
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https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Imagery_and_Maps_WFS/

MapServer/WFSServer 

 

Australian Bureau of Statistics: https://www2.landgate.wa.gov.au/ows/wfsabs_4283/wfs 

To add WFS and WMS layers to QGIS, use the Layer > Add Layer > Add WMS/WMTS Layer.  

 

 

An example of linking to the Landgate imagery is shown below.  

 

https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Imagery_and_Maps_WFS/MapServer/WFSServer
https://services.slip.wa.gov.au/public/services/SLIP_Public_Services/Imagery_and_Maps_WFS/MapServer/WFSServer
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Some services may require you to register for a username and password. 

Access to vector data is via the add WFS (web feature server) option. See below for the list of 

publicly available data (no sign in required) from the Landgate server.  
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6.4 Geoscience Australia 

 

Geoscience Australia (GA) provides an extensive array of national datasets (see this link for more 

information “https://data.gov.au/”).  

Digital elevation data is also available across Australia from Geoscience Australia 

(https://elevation.fsdf.org.au/) at a resolution of 1 arc second (approximately 30 m) and is available 

as a hydrologically conditioned and drainage enforced version (DEM-H). This is a 26 Gb zip file 

and can be downloaded. The author has cut this into UTM zones which are approximately 7 - 8 

Gb in size each zone to improve useability. Depending upon the speed of your PC/laptop, these 

may need to be further cut into 1:1 million map sheet areas. The 9 second DEM (approximately 

250 m) is about 0.8 Gb in size, is also available.  
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Geoscience Australia, 9 second DEM 

Many of these datasets are also available as web services – see this link 

http://services.ga.gov.au/. 

Geophysical data incorporating magnetics, gravity, radiometrics and elevation data can be 

downloaded as vector (point data) or as grid files. Both national and individual survey data is 

available for data held by Geoscience Australia via the Geophysical Archive Data Delivery System 

(https://portal.ga.gov.au/persona/gadds,GADDS) – access via the “Tools” mnu on the right hand 

top side of the window. The DMIRS will hold data for surveys flown for the GSWA. Data can be 

filtered by 1:250 000 map sheet area or by geographic coordinates. Check the projection of the 

dataset before you download, as it may default to geographic coordinates. 

 

http://services.ga.gov.au/
https://portal.ga.gov.au/persona/gadds,GADDS
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Geoscience Australia geophysical data portal.  

 

 

 

GA have also released a new Digital Earth Australia data portal at 

“https://www.nationalmap.gov.au/”. 
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6.5 United States Geological Survey (USGS) 

 

The USGS hold an enormous amount of free data, most of which is accessible via its EarthExplorer 

portal (http://earthexplorer.usgs.gov/). To download the data, you are required to register (free) 

and select a username and password.  

ASTER and Landsat data are two of the remote sensing datasets available from the USGS. These 

datasets are also easily accessed via the Semi-Automatic Classification plug-in in QGIS (see 

Section 11.1). Digital elevation, radar and Lidar data are also available from the USGS. Note that 

Sentinel 2 data is now no longer available from the EarthExplorer portal.  

 

USGS EarthExplorer data portal. 

Use the Register button to create a free account or log in if you have an existing Earth Explorer 

account. Logging in allows you to download datasets. 

Enter the search criteria by using a Landsat path/row identifier, or by using the map or by a 

coordinate. Once you have selected an area, choose the data set you are seeking, add “Additional 

Criteria” if you want to filter your search, e.g. by date range. 

 

 

http://earthexplorer.usgs.gov/
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Each of the data categories have a range of datasets available.  The image below shows an 

example of searching for ASTER data. 
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If there is data available from your search request, you can then examine the thumbnails of the 

scenes and select which dataset is the best one for your purposes. The footprint icon will show 

the area covered by the scene and notepad and pencil icon brings up a better view of the data 

including its metadata. Click on the download icon to download the data. The format of the data 

will depend on the data type and this needs to be researched by the user. 
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6.6 European Space Agency (ESA) 

 

ESA has launched a number of satellites recently in their Sentinel series to observe the land and 

ocean areas for climate and monitoring purposes (see this site 

https://sentinel.esa.int/web/sentinel/home). For geological work, the author has found the Sentinel 

2 data is most useful. The Sentinel 2 mission monitors variability in land surface conditions, and 

its wide swath width and high revisit time (5 days) will support monitoring of changes to vegetation 

within the growing season. The coverage limits are from between latitudes 56° south and 84° north 

(ESA). 

Currently the best way to select and download the Sentinel data is via the ESA Copernicus Open 

Data portal (https://scihub.copernicus.eu/dhus/). Register for a free login and passwords at the 

portal. 

The following description is taken from the ESA Sentinel website. 

“Sentinel-2 products available for users are listed in table below. 

Name High-level Description Production & Distribution Data Volume 

Level-1C 

Top-of-atmosphere 

reflectances in 

cartographic geometry 

Systematic generation and on-line 

distribution 

600 MB (each 

100x100 km2) 

Level-2A 

Bottom-of-atmosphere 

reflectance in cartographic 

geometry 

Systematic generation and on-line 

distribution and generation on user side 

(using Sentinel-2 Toolbox) 

800 MB (each 

100x100 km2) 

Products are a compilation of elementary granules of fixed size, within a single orbit. A granule is the minimum 

indivisible partition of a product (containing all possible spectral bands). 

For Level-1C and Level-2A, the granules, also called tiles, are 100x100km2 ortho-images in UTM/WGS84 

projection. The UTM (Universal Transverse Mercator) system divides the Earth's surface into 60 zones. Each 

UTM zone has a vertical width of 6° of longitude and horizontal width of 8° of latitude. (see Figure 1). Tiles are 

approximately 600 MB in size. Tiles can be fully or partially covered by image data. Partially covered tiles 

correspond to those at the edge of the swath. 

The continuous acquisition of Sentinel-2 image data in a given MSI mode is called a "datatake". The maximum 

length of an imaging datatake is 15,000 km (e.g. continuous observation from northern Russia to southern 

Africa). All products contain granules/tiles from a single datatake. A datatake is presented inside a product as a 

set of one or more datastrips (corresponding to acquisition segments downlinked to different ground stations).” 

 

http://geodownloads.dmp.wa.gov.au/downloads/dasc/Static/Resources/Map_Services/Web_Map_Service_definition.pdf
https://scihub.copernicus.eu/dhus/#/home
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Level-1C product tiling 

The Sentinel 2 series A and B satellites are of relevance to geology as they have a high spatial 

resolution and 12 bands of spectral data. The multispectral imager (MSI) covers 13 spectral bands 

(443 nm–2190 nm) with a swath width of 290 km and spatial resolutions of 10 m (4 visible and 

near-infrared bands), 20 m (6 red-edge/shortwave-infrared bands) and 60 m (3 atmospheric 

correction bands). The Sentinel 2 satellites main applications are in monitoring agriculture, forests, 

land-use change, land-cover change; mapping biophysical variables such as leaf chlorophyll 

content, leaf water content, leaf area index; monitoring coastal and inland waters; risk mapping 

and disaster mapping. 

Spectral bands for the SENTINEL-2 sensor 

Band 

number 

Central wavelength 

(nm) 

Bandwidth 

(nm) 

Spatial resolution 

(m) 

1 443 20 60 

2 490 65 10 

3 560 35 10 

4 665 30 10 

5 705 15 20 

6 740 15 20 

7 783 20 20 

8 842 115 10 

8a 865 20 20 

9 945 20 60 

10 1380 30 60 

11 1610 90 20 

12 2190 180 20 

 

The table below compares Sentinel 2 with other commonly used satellite sensors.  



QGIS In Mineral Exploration   

 P a g e  | 22 
 

Common Name Band Range (μm) Landsat 5 Landsat 7 Landsat 8 Sentinel 2 MODIS 

Coastal 0.40 - 0.45   1 1  

Blue 0.45 - 0.5 1 1 2 2 3 

Green 0.5 - 0.6 2 2 3 3 4 

Red 0.6 - 0.7 3 3 4 4 1 

Pan 0.5 - 0.7  8 8   

NIR 0.77 - 1.00 4 4 5 8 2 

Cirrus 1.35 - 1.40   9 10 26 

SWIR16 1.55 - 1.75 5 5 6 11 6 

SWIR22 2.1 - 2.3 7 7 7 12 7 

LWIR 10.5 - 12.5 6 6 10, 11  31, 32 

 

The Sentinel data can also be accessed via the Sentinel portal after registration (Sign Up button), 

see this link https://scihub.copernicus.eu/dhus/#/home. 

 

 

 

After logging on to the portal, scroll to your area of interest and highlight a rectangle for your data 

search. This method of data selection is less intuitive than the USGS EarthExplorer data access 

and I would use a Sentinel 2 tile id to zoom to the area of interest.  

A Sentinel tile index covering the world can be downloaded as a shapefile from the ESA website. 

Sentinel 2 data can also be downloaded using the QGIS plug-in “Semi-Automatic Classification” 

which is discussed below. 

Note that radar data is now available from the Sentinel 1 mission. 

https://scihub.copernicus.eu/dhus/#/home
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6.7 30 m SRTM Tile Downloader 

 

The SRTM-Downloader plugin allows the user to download tiles into their map window and these 

can be saved. Note that you will need a USGS EarthExplorer portal login (free). The dtm tiles are 

downloaded in one degree tiles in hgt grid format (which QGIS reads with no problem). 

You can also use this link to access the 30m SRTM tile data - http://dwtkns.com/srtm30m/. You 

will need to add your USGS EarthExplorer username and password.  

 

 

 

These images are in jp2 (jpeg2000) format which have the image registration information 

incorporated in the file. QGIS reads and registers these images.  

 

6.8 Coordinate Reference Systems 

 

When using GIS data, it is very important to know the coordinate reference system (CRS) of the 

data. Choosing the wrong projection will misplace the data or prevent it from appearing on your 

map. QGIS can re-project data on-the-fly (OTF) when bringing data into a map window that has a 

different CRS to the file being imported. If QGIS cannot recognise the projection of the layer being 

imported, it will flash a yellow warning banner and usually defaults the layer projection to WGS 

84. Open the layer properties for the layer and correct its projection.  

Note that the CRS in the PROJECT PROPERTIES dialog box affects the way the data is displayed 

in the map window. The CRS dialog box in the LAYER properties box affects where the points are 

located on the planet. It is very important to know the CRS of the data being imported i nto the 

map window. 

http://dwtkns.com/srtm30m/
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The CRS dialog box remembers your recent CRS used and these can be quickly selected from 

the “Recently Used…” information box. If you have not used a particular projection previously, you 

can type in the CRS name or EPSG number of the projection into the “Filter” box. For example, 

the Australian GDA94 geographic CRS has an EPSG of 4283. Note that if you type “GDA94” into 

the filter box it may give you an option of GDA94 as a Projected Coordinate System (EPSG 4938), 

this is incorrect and will cause problems when trying to display GDA94 lat/long data. Always check 

you have selected the correct CRS.  

GDA94 UTM zones can be easily selected by entering the EPSG starting with “283”, then add the 

zone number, for example GDA94 zone 50 would be EPSG 28350. GDA2020 has a lat/long EPSG 

of 7844 and a UTM EPSG of 78xx where xx is the GDA zone number. 

WGS84 UTM zones can be selected using “327” then the zone number for the southern 

hemisphere and “326” plus the UTM zone for the northern hemisphere.  

 

 

The lower map window shows the area of the world where the projection is valid.  
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If you are using a local grid with no real world projection, you can select the “No Projection” tick 

box at the top of the window. 

Note that in recent QGIS releases you get a coordinate transformation window open up when 

QGIS is reprojecting layers on the fly from WGS84 projections. QGIS is reminding you that the 

WGS84 projection transformations are only accurate to 2 to 3 metres.  
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7: GEOLOGICAL DATA 

Geological data is varied in nature but is usually either as points, lines, or polygons. Geological 

mapping comprises the collection of points using a GPS, with lines and polygons drawn as an 

overlay on aerial or satellite images. More commonly these days is that the data is collected in a 

portable field device and uploaded to the GIS database.  

When editing data, remember that in QGIS, it is a click to select and then click to the location to 

be moved – not a click and drag! 

The following discussion covers a variety of tasks commonly associated with field data collection 

and interpretation. Detailed editing tasks will not be discussed as there are numerous resources 

available on the web, in the QGIS User Manual and various books. A variety of tips and tricks can 

be found in section 13.  

The Android tablet application “QField” and MerginMaps are available for tablets and more details 

on this will be added in the near future. They can both be used in the field for data collection and 

mapping. 

QGIS can sometimes have problems when digitising into layers with differing projections in the 

map window. It is recommended that digitising be done on layers in one projection at a time. The 

new file can be reprojected at subsequently into a different projection if required. 

Note also turn off the auto-save plugin, if you have this enabled, as it may cause problems during 

digitising. 

Details on the digitising and editing functions can be found in the “QGIS User Guide – Release 

Testing” (for version 3.28) document which can be found here https://docs.qgis.org/testing/pdf/en/. 

This guide gets regularly updated. 

 

 

 

 

https://docs.qgis.org/testing/pdf/en/
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7.1 Point Data 

 

Field mapping data is collected by various methods. The most basic version and that used by the 

“old school” is to collect data in a field book and then enter it into a spreadsheet for import into a 

GIS. Field data collectors vary in their formats and so the user will need to determine what is the 

best option for their data import. Always include the datum and projection zone (if applicable) 

when compiling vector data. 

GPS points collected in a GPS are easily brought in to QGIS by importing a GPS “gpx” file or in 

some cases direct download of the GPX file from the GPS. Tracks and waypoints downloaded 

from the GPS in *.gpx format can be opened via the Data Source Manager and the GPS tab. GPX 

files from Garmin GPS units are usually in WGS84 geographic coordinates (Longitude and 

Latitude, decimal degree format) by default. GPS points can be uploaded to a GPS using the POI 

plugin. 

Comma separated variable or “CSV” files are a good simple way to import point data and can be 

an alternative way to import spreadsheet data when there are problems importing Excel files. If 

you do have a problem with importing an excel file, save the file in CSV format and import into 

QGIS. Note there can be problems importing large Excel or csv files, e.g. with QGIS scrambling 

column data, if this is the case, then use the tab delimited text export option from Excel. 

Complex CSV files containing a variety of field types can be imported using CSV format files 

(*.csvt). QGIS can read field data types from an OGR CSV driver compatible "csvt" file. This is a 

txt file alongside the data file, but with a "t" appended to the file name extension. The file should 

just contain one line which lists the type of each field. Valid types are "integer", "real", "s tring", 

"date", "time", and "datetime". The date, time, and datetime types are treated as strings in QGIS. 

Each type may be followed by a width and precision, for example "real(10.4)". The list of types 

must separated by commas, regardless of the delimiter used in the data file. An example of a valid 

format file would be:  

"integer","string","string(20)","real(20.4)". 

Another option for importing csv data is to load into Excel and check the field types for each field 

before importing. Excel files are imported using the “Spreadsheet Layers” plugin. This is found 

under the Layer > Add Layer > “Add spreadsheet layer” menu.  It is especially important to check 

the data is being correctly imported. 

Point geological mapping data such as bedding, joints and outcrop observations can be entered 

via a spreadsheet where columns can be created to cater for items such as coordinates, 

observations, and photo references. Remember to always include the datum and map projection 

data in the file. Symbol file names (full path required) can also be entered into the spreadsheet 

that will allow QGIS to select the correct symbol and then orientate it using a rotation angle for the 

correct strike or plunge. An example is shown below of the WAROX (GSWA mapping data, csv 

format) data from the GSWA Bow 1:100k geological map. Additional columns would be required 

with symbol file names to allow QGIS to select the appropriate symbol, or alternatively you can 

choose a “Categorise” symbol style option and edit the symbols for each category manually.  
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Below is an example of the “categorised” features of the WAROX data for the GSWA Lissadell 

250k map sheet with features manually changed by clicking on each symbol. Once this has been 

done, remember to save the symbols by using the “Style” button and “Save style” to a QGIS qml 

style file (e.g. GSWA_WAROX.qml). This style file can then be used to recall these styles. You 

can choose the “save as default”, which creates a qml file with the same file name as the shape 

file and when you open the shape file, the qml file will be used to determine the way the features 

are displayed for this layer. Styles can also be saved to a Geopackage file. 

 

 

To create a new empty points layer, use the menu item Layer > Create Layer > New Shapefile 

Layer and select a point layer type (especially important to check the geometry type! And 

CRS). Add the required data columns and data types (text, integer, decimal number, date) to 

attach to each point. Remember shapefile column names are limited to 10 characters and any 

names longer than this will be truncated. When creating a new vector layer to digitise data, ensure 

the layer is the correct type, i.e. point, line or polygon, that it has the correct map projection and 
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add the necessary columns to be able to enter the relevant field data for each feature. Save the 

file with an appropriate file name. Note that additional fields can be added later if needed. When 

digitising into a Geopackage file the feature id will be automatically incremented.  

 

 

 

 

Note the Type “Real”, Length and Precision options where you can restrict the size of the data 

entered (e.g. UTM eastings length 9 - 6 figures, decimal point and two decimal places). Note that 

a negative sign, as per the dip, does not use a length, so the dip field in this example could have 

a length of 5 (00.00 to -90.00).  

Points can be moved in the map window by using the “Move Features” icon in the point edit menu. 

The layer requires to be set as editable. Note that the coordinates in the underlying table will not 

change and these coordinates need to be updated using the “$x” and “$y” geometry tools in the 

“Attribute Table”. 
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Move tool highlighted in editing toolbar. 

If you do move points, remember to update the Easting and Northing values in the table using the 

geometry operator “$x” for Easting and “$y” for Northing. Remember to select the correct column 

to update! If you fail to do this the coordinates shown in the table will be incorrect. Remember also 

that the updated coordinates will be in the project projection coordinates.  Also remember to save 

your edits. 

 

 

There is an algorithm in the Processing Toolbox that will create X-Y columns from point data and 

this is accessed via the Processing Toolbox > Vector Table > “Add X/Y Fields to Layer”.  
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7.2 Outcrop Photographs 

 

Photographs of outcrops and report pdf files can be attached to an observation point and allow a 

point and click to access the photo or report.  

There are three ways to display photos at points. There are two options using the Import Photos 

plugin, and the third option is going via the Layer Properties > Actions (thanks to Mike Erceg for 

explaining this process) The last two options require the full path to the photo file to be identified. 

Import Photos Plugin 

If your photos are geo-tagged, i.e., they have their coordinate locations imbedded in the file, then 

another alternative option is to use the “Import Photos” plugin. Most smartphones take geo-tagged 

photos unless the location data option has been turned off for photos. I use a Pentax K -1 DSLR 

and that camera has an in-built GPS, so all photos are automatically geo-tagged. Most smart 

phones will have embedded GPS coordinates in the photos unless this location feature has been 

turned off. 

To use the Import Photos plug-in, run the “Import Photos” option and select the directory where 

the photos are located and where you want to store the resulting shape file (this will have all the 

photo information extracted from the photo file). Choose a suitable filename and press OK. The 

layer will them be created and using the Plug-Ins > Import Photos > Click on Photos (use a double 

click), the photos in those locations will be displayed.  
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Import Geotagged Photos 

This is the simplest option if your photos are geotagged. Most smartphones automatically geotag 

photos unless this “location” feature is disabled. Use the Processing Toolbox > Vector Creation > 

Import geotagged photos algorithm. The resulting table will be created as below.  

 

 

To display photos, you use a widget in Layer Properties > Attributes Form. In the above example, 

the “photo” contains the link to the photo and we can use this to tell QGIS where to find this photo.  

Open the Layer Properties of the file and select the “Attributes Form” tab. Select the field with the 

link to the photo (“photo”), then change the widget type to “Attachment”.  
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Leave everything else as default, see image below. 

 

 

If you are importing photos via a different method, you will have to change some of the field values. 

For example, the default path to the image folder, tick “Relative paths” and “Relative to default 

path” option. Note the central dialog scroll down box can be difficult to locate but note the scroll 

bars on the right-hand side. 
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Scroll down the window the central part of the dialog box, past the “Storage Mode” to the 

“Integrated Document Viewer” section and select “Image”. Leave the sizes to Auto.  
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Apply the changes. In the map window, use the “Identify Features” icon to click on a point with a 

photo (this should open an Identify Features dialog box), then in the identify features dialog box, 

highlight the point (if you have multiple points in the Identify Features dialog box), open the “form 

view” (top left icon in the Identify Features dialog box). This will open a new dialog box which may 

require re-sizing to see the image. If the point with the image is not at the top of the list, select the 

point and then open the form. 

Once you have modified the Attribute Form, to display the photo, use the “identify” tool to click on 

the point (with the Layer highlighted in the Layers panel). If there is more than one point selected, 

QGIS will display the “identify Results” window showing the various points selected. Highlight the 

photo point you wish to display and then use the “View Feature Form” icon to show the information 

for that point and the photo. The form can be re-sized to enlarge a photo display. 
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This method of displaying photos can also allow you to display the comments for example that 

accompany an image. Note this link is saved with the project and not in the layer properties.  

 

Forms for Improved Viewing Photos Using the File Widget and Tabbed Pages 

You can display photos and data in tabs using a widget in Layer Properties > Attributes Form. 

Select the “Drag and Drop Designer” option from the top combo box.  
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Using the green plus symbol, create two new “Container” items – “Data Entry” and “Photo”. Drag 

the “Photo” and “Comments” into the “Photo” item (by click hold and drag over the item name) – 

this will display the image with the comments. Drag the other fields into the “Data Entry” item – 

you can remove fields by using the red minus button.  

This will result in a tabbed window opening where we can switch between the data and the photo 

and makes it easier to see the photo. This works well in QField on a tablet device where space is 

limited. 
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Select the field with the file location, e.g. “PhotoFile” f ield, then change the widget type to 

“Attachment”. Enter the default path to the image folder, tick “Relative paths” and “Relative to 

default path” option. Note the central dialog scroll down box can be difficult to locate but note the 

scroll bars on the right-hand side. 

 

Scroll down the window the central part of the dialog box, past the “Storage Mode” to the 

“Integrated Document Viewer” section and select “Image”. Leave the sizes to Auto.  
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Drag the “Photo” item under the “Data Entry” item. This will then open up the image by default. 

 

 

Apply the changes. In the map window, use the “Identify Features” icon to click on a point with a 

photo (this should open an Identify Features dialog box), then in the identify features dialog box, 

highlight the point (if you have multiple points in the Identify Features dialog box), open the “form 

view” (top left icon in the Identify Features dialog box). This will open a new dialog box which may 

require re-sizing to see the image. If the point with the image is not at the top of the list, select the 

point and then open the form. 

Note that you need to save a new style file to remember these settings.  

If there is more than one photo/point at the location, you need to select the point in the “Identify 

Results” window and hit the “open feature form icon in the top left-hand side of the Identify Results 

window. 
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QGIS In Mineral Exploration   

 P a g e  | 42 
 

 

This method of displaying photos allow you to display the comments for example that accompany 

an image. Note this link is saved in the layer properties but only  if you save the style. 

 

Viewing Photos by the Action Tab 

The third method to display photos is to use the Action option, open the Layer Properties of the 

layer and select the Action tab. Double click on the Open URL – Open File option. 

 

This will open the dialog box shown below. 
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In the dropdown box near the bottom of the box, select the field with the photo location and click 

“Insert” to put the path into the Action Text window. Use the Windows file explorer to navigate to 

the directory that holds the photos, copy the path and paste it in front of the square brackets that 

holds the photo file name (as shown in the image below).  
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With the “Identify Features” activated for the cursor, right click on a point with a photo and the 

following will be displayed over the point. 

 

Note there are two photos at this location. 
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Select the “Open File” option and the photo will be displayed.  

 

 

 

7.3 Line Data 

 

Line data includes such items as contacts, faults and trend lines and are usually plotted on aerial 

or satellite imagery overlays. Surface mapping data can be digitised by scanning in the hard copy 

photo overlay into QGIS (via raster registration) and tracing the linear features, or by direct 

digitising on screen using the field mapping data as a guide. 

When creating a new vector layer to digitise the data, ensure the layer is the correct type, line 

type for example, has the correct map projection and add the necessary columns to be able to 

enter the relevant field data for each feature. Save the file with an appropriate file name. 
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QGIS can automatically assign a unique id numbers for each line after the creation of a group of 

lines. Open the Layer Properties > Fields, select the id field and click on the field calculator icon 

and choose “Update existing field”, select the id field, select the “row number” operator in the 

Variables list. Now when you save the file it will allocate a unique id to each feature. Thanks to 

Chris Franklin for noting this feature. If you are digitising into a Geopackage line file, the id field 

will be autonumbered. 
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Specific line styles can be added via the top menu Settings > Style Manager option. Geological 

line styles have been created as *.xml files and are imported using the “import” option, selectable 

from just above the Close button in the Style Manager dialog box. Import each style to a category, 

e.g. Contacts, so they are easier to locate.  
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Contact the author, if you would like to download these style files for contacts, folds, joints, or 

faults which are based on the USGS symbol sets. 

Note that the line direction can be reversed to get the tick symbols to plot on the opposite side of 

a line, e.g. fault ticks, using the “Reverse Line Direction” in the Advanced Digitising Toolbar (v3.4 

or higher). 

Line styles can also be created directly via the Style tab of the layer menu. Add an extra layer 

(using the green plus button) to combine lines and markers. There are numerous styles and 

options to choose from. Remember to save the style using a “*.qml” or “Save as Default” option 

when finished editing the line style. 

You can combine many line styles into the one vector line file, providing you have a colum n by 

which the lines can be classified, e.g. feature type “contact”.  

 

 

 

Lines can be edited by first highlighting the layer in the Layers panel and clicking the enable 

editing icon (pencil). A pencil symbol will then appear next to the layer being edited in the Layers 

panel. Remember to save your edits when exiting the edit mode. When the line is editable, there 

will be red crosses on the vertices. Click on the “node” tool (seventh button along from left, next 

to rubbish bin) then click near a vertex to highlight the vertices, select the vertex you want to move 

and simply click where you want to move it to. Note QGIS v3 uses “click-click”, not “click and drag” 

methodology. To add more vertices, hover over the line and click on the small red cross that 

appears. This will create a new point which can then be moved. 

See the QGIS User Manual here https://docs.qgis.org/testing/pdf/en/QGIS-testing-UserGuide-

en.pdf for up-to-date information on editing. The Testing Version applies to v 3.28. 

 

https://docs.qgis.org/testing/pdf/en/QGIS-testing-UserGuide-en.pdf
https://docs.qgis.org/testing/pdf/en/QGIS-testing-UserGuide-en.pdf
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7.4 Plotting Drill Hole Traces and 3D Drill Data Display 

There are two options to displaying drill hole traces on maps. One is to create the horizontal trace 

and use the “Shape Tools” plugin to plot the lines, or you can use the new “Geoscience” plugin. 

Both methods are described here. 

7.4.1 Geoscience Plugin 

The “Geoscience” plugin (with thanks to Roland Hill) has allowed the plotting of drill hole traces 

and colour coding of the drill hole traces in QGIS easy. Cross sections can also be created. The 

drill set up screen allows you to select the collar and survey files. You will need to install the 

plugins in the Plugin Manager. See the documentation for more details 

(https://www.spatialintegration.com/geoscience-plugin-for-qgis/). 

If your tables have commonly used field names, then the plugin will pick the fields.  
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The Desurvey option calculates the 3D trace of the drill hole. The 3D coordinates of each sample 

are calculated when you “attach” the downhole data, like assays or lithology, to the drill hole trace.  

Top, bottom and mid-points of each downhole interval will be calculated in xyz coordinates. The 

data to be displayed down the drill hole trace needs to be imported as a non-spatial file with hole 

id, from, to and data fields. Down hole data can be assays, lithologies, or other data. If the 

downhole data fields are in a csv file format, make sure this is imported vis the Data Source 

Manager > Delimited Text option so that QGIS interprets the correct field types , particularly for 

the from and to fields which must be numbers. The help menu for the plugin describes the workflow 

and a link to the web page (https://www.spatialintegration.com/). Mid-point coordinates are 

calculated and can be downloaded using the downhole data output as a csv file for use in other 

programs like ioGAS or LeapFrog. 

 

To enable labelling of assay results down hole, use the 3D mid-points of the assay intervals. This 

will then allow the display of multiple assay values by duplicating the assay -mid-point layer and 

choosing the data to be displayed. To display the lithology as a hole trace colour, make sure you 

include the lithology layer in the desurvey option, then use the symbology tab to colour by lithology 

(by categorise).  

The drill hole traces (the desurveyed layer with the down hole data attached) can be coloured via 

the “Symbology” tab using any attribute. Note that when you import the downhole data, e.g. 

assays, make sure the “from”, “to” and assay values are recognised as numbers not text.  

To create a cross section, use the “Section Manager” and using the “Use Map Canvas” and select 

the envelope width, draw the required section line. 

 

https://www.spatialintegration.com/
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The cross section will be created in a “new” location on the map. To get back to the collar positions, 

right click on the collars layer and “zoom to layer”.  
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Cross section plot with the hole trace coloured by lithology and the assay values of two elements 

displayed using their mid-point locations. 
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7.4.2 Alternative Way to Plot Drill Hole Traces on Plan 

Surface drill hole traces can also be plotted on plans using the Shape Tools plugin. To plot drill 

hole traces, a collar file with collar coordinates, azimuth and horizontal projected distance columns 

are required. The horizontal distance – trace length – is calculated using the following formula; 

Trace length = hole length * cos(radians(dip)) 

 

 

Note if down dip is negative, multiply the dip by -1 (as in the above example). 

 

 

Using the Shape Tools plugin (from icon task bar) select the Create icon and the Line tab.  
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Select the Azimuth column for the hole azimuth and the distance field for the length of the hole 

trace. Check the units of distance is in metres. The result should look something like below with 

the hole traces created in a new virtual file – remember to save it with a relevant name. 
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7.4.3 Displaying Drill Hole Traces in 3D 

It is also possible to display drill hole data in 3D using the “QGIS2threejs” plugin. All that is required 

it to have the 3D coordinates for the sample points to be calculated. This is a simple display option 

and will hopefully be superseded with the development of the drill hole and cross section module 

planned for the future (“OpenLog” plug-in being developed by Oslandia). The QGIS2threejs plugin 

displays the centre points in XYZ coordinate space. The sampling data can be coloured according 

to any attribute in the file, e.g., assay values of Cu. 

To display the downhole data, the 3D coordinates are required for the drill hole traces. In the 

example below, the XYZ mid-points have been calculated for assay intervals. In the main map 

window, then DEM, Google Earth satellite image and the file containing the 3D coordinates of 

surface and drill hole samples have been loaded. The DEM layer and sample layer are not 

displayed (but loaded).  

 

 

When opening the QGIS2threejs plugin, select the DEM for the elevation and right-click on the 

samples layer to select the z coordinate. 
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The 3D image can then be rotated and tilted as desired. The surface satellite image has been set 

to 30% transparency to be able to see through the surface. 

 

 

Always remember to save your projected regularly.  
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7.4.4 Extracting Maximum Values for Drill Holes 

This can be done at least two ways. The first way is to calculate the drill hole statistics and group 

by drill hole (algorithm “Statistics By Category”). This method requires coordinates for all assay 

points. 

The second method is to use an SQL query on a Geopackage file. Save the collar file and the 

assay file into a Geopackage, then use the DB Manager to connect to the Geopackage. Open the 

SQL Window, second icon from left, and then run the SQL query as shown below. Do not forget 

to add the “geom” column to the query so the resulting layer can be plotted. Each point will have 

the max value attached. 

 

 

To select the maximum assay value by drill hole, use the “maximum” function.  
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7.5 Polygon Data 

Polygon data is added by creating a new polygon layer (Layer > Create Layer > New Shapefile 

Layer or New Geopackage Layer), selecting type “polygon”, set the projection information and 

enter the additional fields for the polygon file.  Note that if you are creating a Geopackage file, 

QGIS will auto-number every new feature when digitising. 

 

The additional columns might hold data such as geological code, geological descriptions, etc. 

Remember to select the correct field type (string, number, and precision, etc) and, remember that 

field names are limited to a length of 10 characters in shapefiles – but not in Geopackage files. 
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When creating new objects in a shape file, every new polygon should be assigned a unique “id” 

number. If you keep these unique, then it is easier to select and alter polygons which can be then 

selected by their id. Note that digitising into a Geopackage file will automatically number the id 

field.  

To add a new polygon, highlight the polygon layer in the Layers panel, and toggle the editing 

button (pencil icon). Numerous polygon options are available - see the second row of menu. To 

add a new polygon, use the Add Polygon Feature icon. Hover over each icon for an explanation 

of the icon actions. If not all the digitising and advanced digitising options are not show, check the 

top menu View > Toolbars options. 

QGIS can also assign a unique id numbers for each polygon in a shape file after digitising is 

compete. Open the Layer Properties > Fields, select the id field and click on the field calculator 

icon and choose “Update existing field”, select the id field, select the “row number” operator in the 

Variables list. Now when you save the file it will allocate a unique id to each feature.  Thanks to 

Chris Franklin for noting this feature. 

 

 

If you want to calculate areas of polygons, add an “Area” column to the polygon table. Note you 

must set the projection to a metre projection, e.g. UTM, not geographic degree units, and select 

your units in the Project Properties > General > Measurements dialogue box. You can then 

populate this field by using the calculation option in the Attribute Table option. Make the layer 

editable and then use the $area function to calculate the relevant field area.  

Note that the units of area are set in the Project Properties > General > Measurements dialogue 

box. These units can be changed on the fly, but you need to refresh the values in the calculated 

area column to reflect the new units. The area can also be viewed by selecting the Layer 
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Properties > Display > Field option so that the area can be displayed when you hover the mouse 

over the polygon when the Info Tool is activated. 

 

 

 

Areas can also be calculated via the “Calculate Geometry” plugin. Right click on the layer name 

in the Layers Panel and select “Calculate Geometry”. The Calculate Geometry plugin allows you 

to select your area units. Perimeters can also be calculated this way. Make sure you do some 

check areas to ensure your results are correct. 
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To digitise a polygon, make the layer editable and choose the “Add Feature” polygon icon (4th from 

the left). Click around the polygon using left mouse clicks and finish the polygon with a right mouse 

click. Nodes can be shifted and added-deleted using the node icon, as per the line editing options.  

Creating Drop-Down Lists for Data Entry 

A drop-down list can be created in QGIS to allow for the attribution of vector items. The use of a 

drop-down list prevents typographical errors in data entry and can be used to restrict non-standard 

item names. You can use data from an existing layer or use a csv file for the source of the drop -

down box data. 

The example below shows a csv file that has been used to apply attributes to the polygon layer.  

 

In the Layer Properties, select he Attribute Form tab, and change the widget type to “Value Map”. 
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The Form Value Relation is used to apply multiple nested dropdown boxes for use in pre -set data 

entry options. This is useful for entering specific rock types, geological codes or formation names.  

The following is from North Road Consulting who completed a crowd funding campaign to get this feature into 

the core component of QGIS.  

“What happens is you have pick lists that can change based on other values. Have a pipe? It can be made out of 

W, X, Y, and Z. Is it a Water Pipe? It can only be made of X and Z. Wastewater Pipes can only be made of W 

and Y. 

Here is my walk through. I have a point layer and that point layer has a type and a subtype. I stored this all in a 

Geopackage by the way. The type drives the subtype. You select A and you can only have red or blue. Maybe B 

is green and white. There are two tables to help with this process tableA is 2 fields: a primary key and a value. 

TableB has three fields: a primary key, a value, and a foreign key that relates back to Table A.  From that you 

can see Type A can only have a value of Red and Blue. Type D can only be Black and Gray. 
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The point layer has two attributes of concern: type and subtype. Type will be A,B,C, or D. Subtype will be a 

range of colours that Match the Type picked. If you right click the layer and select attribute forms you can 

assign a form for data entry. In this case for type the key column is the primary key and the value is the type. 

Note the Widget type is Value Relation! 

 

Lets looks at the subtype field. The key column is the Foreign Key (the part that relates it back to table A). The 

value column is the subtype. The magic is this – if you look at the filter expression:“fk” = current_value(‘type’) 

. See below. 
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The foreign key equals the value of the type widget. When you add a point, you’ll see the type drives the subtype. 

 

In summary, if you select type A, you will only get an option to select colours red and blue. “ 

 

Value Maps and Form Value Relations are useful tools for adding data. For geological data, you might 
have a list of rock classes (igneous, sedimentary, etc) and a list of lithologies (basalt, granite, 
sandstone, etc) for polygon data, or observation type (bedding, joint, vein, etc) for point data. 
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7.6 Geological Symbols and Geological Patterns 

Geological symbols can be either specific geological fonts (True Type Fonts) or SVG (scalable 

vector graphic) symbols. Geological symbols can be downloaded from the internet for free use in 

QGIS (https://github.com/GISsimbology/symbols). On Windows systems, geological symbol fonts 

need to be installed by right-clicking on the font file name and selecting Install . Note that some 

fonts, particularly the ESRI fonts, are proprietary and not free use.  

Geological Fonts 

Four font sets are available from Geoscience Australia and include ESRI Geology AGSO 1 to 3 

(esri_500.ttf, ESRIGA_0.ttf and ESRIGA_4.ttf), GeoscienceMining (GEOSM_.ttf) and 

MiningFossilTopo (MINIFT_.ttf). Other geological and cartographic fonts may also be available 

depending upon what other software you may have installed (previous MapInfo or ESRI  fonts may 

already be installed on your system and could also be used). Fonts installed on Windows can be 

accessed via the Windows run box and typing “fonts”. 

Geological font symbols are accessed via the Layer properties > Style tab and choose the symbol 

layer type as “font”. All the fonts installed on your computer will be accessible and you will need 

to search through the installed fonts to find the relevant font file and then the relevant font symbol. 

Adjust the font size to suit. 
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SVG Symbols and Patterns 

A selection of svg geological pattern files shown in the appendix were initially sourced from 

Stefan Revets’ page 

(https://sourceforge.net/projects/qgisgeologysymbology/files/?source=navbar ) and modified to 

allow the overprint pattern to be coloured. Also see this page 

https://github.com/afrigeri/geologic-symbols. An alternative location for geological svg patterns is 

https://github.com/BC-Consulting/FGDC-4-QGIS. The NSW geological survey also supply 

symbols for their state wide geological maps 

(https://search.geoscience.nsw.gov.au/product/9232) and are based on the USGS FGDC 

symbols and the symbols are supplied in folders based on the FDGC documentat ion. 

 

https://sourceforge.net/projects/qgisgeologysymbology/files/?source=navbar
https://github.com/afrigeri/geologic-symbols
https://github.com/BC-Consulting/FGDC-4-QGIS
https://search.geoscience.nsw.gov.au/product/9232
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SVG files can be stored anywhere but the default location for the standalone install option is the 

Program folder, for example C:\Program Files\QGIS 3.26\apps\qgis\svg. Note that if you install 

QGIS via the OS4Geo option, the svg files will be located in the “C:\OSGeo4W64\apps\qgis\svg” 

for the long-term release version, or the “C:\OSGeo4W64\apps\qgis-dev\svg” folder for the 

development version. It is recommended that this folder is used for the additional geological 

symbol and patterns so QGIS will find these by default and you will not require to specify and 

additional svg directory location. If you upgrade your version of QGIS, you may need to copy your 

extra svg files back into this folder.  

Alternatively, save the SVG folder to another separate folder and point QGIS to that folder using 

the Settings > Options > System tab. 

 

 

To use the geological patterns, for example, you would categorise the layer based on a geological 

code and then allocate each code a specific pattern fill , and background polygon layer. The image 

below shows the result of “Categorising” the geology and colouring each geological code type.  
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Note that you have options for size and rotation of the patterns or symbols. The SVG symbols and 

patterns have discrete file names which can be used to automatically assign symbols and patterns 

in the “Data Driven Override” of the layer properties file window. 

 

 

 

Coloured backgrounds can be added to the polygon fill by adding another layer in the Symbol 

Selector dialog box. Add a new symbol layer by using the green plus symbol and move it to the 

bottom using the down arrow key below the display box. 
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For assistance in selecting colours, go to the “Color Brewer” web site (http://colorbrewer2.org) 

where there is a vast array of colours and their specifications available.  Colour specifications can 

be specified in QGIS via their hex, RGB or CYMK number. 

If you have favourite fill styles, these can be saved as “Favourites” which are then quickly 

accessible via the Symbol Selector dialog box. 

 

The svg fills can also be “embedded” into the file via the “Advanced” options and this allows the 

files to be used by other users that may not have the relevant svg files installed on their 

machines. 
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7.7 Geological Line Styles 

Linear geological features can be displayed by manually editing the line style in the Layer 

Properties > Style tab, or by using line styles set up in the top menu Settings > Style Manager 

window. Full details of how to construct various line styles can be found in a comprehensive 

document put out by the USGS and can be found here 

https://ngmdb.usgs.gov/fgdc_gds/geolsymstd/fgdc-geolsym-all.pdf. 

Style (*.xml) and symbol (svg) files can be found here at Stefan Revett’s site 

https://sourceforge.net/projects/qgisgeologysymbology/files/  and in the NSW QGIS Symbols in the 

“\QGIS_Symbols\FDGC_GeologySymbology\svg” folder. Line styles include geological contacts, 

faults, folds, and joints and are based on the FDGC symbology. 

On the main menu, go to Settings > Style Manager and select the Import option in the small box 

down on the lower left-hand side of the dialog box (looks like two blue lines with dots). Save each 

group with a name (“tag”) so that you can easily identify which line style group you want to display.  

 

Navigate to where your line styles are stored. Import each one (e.g., contact, fold, fault and joint). 

Remember to add a “tag” so they can be easily selected in the Style Manager.  

In the Symbol Selector dialog, select the “Symbols in group” drop-down box, select “contacts” (or 

whatever you called this line style group). Select the line style you want and hit OK. This method 

can be used to modify all the other line styles. To save these line styles remember to save the 

Style as default in the main Style tab window (under Sty le > Save as Default). 

If you have multiple line styles, make sure you have a column in your table to allow the line types 

to be “Categorised” so that specific line types can be allocated to different line types.  

https://ngmdb.usgs.gov/fgdc_gds/geolsymstd/fgdc-geolsym-all.pdf
https://sourceforge.net/projects/qgisgeologysymbology/files/
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Any of these line styles can be edited manually by selecting the layer in the top window. Note that 

you change the line direction, e.g. fault ticks on other side, by using the “Reverse Line Direction” 

in the “Advanced Digitising Toolbar”. 

 

7.8 Labelling Features 

Features can be labelled via the Labels tab in the Layer Properties window for each layer. There 

are many ways to place labels and format them. I will give some examples typically used in 

geological applications below but there are many other options which you are encouraged to 

explore (see QGIS User Guide – section 12.3.3 and Graser and Peterson 2016 – Part 2). Note 

that you can have the labelling panel open and docked by pressing F7, and when you make 

changes to the labels these are immediately displayed in the map widow. This method removes 

the requirement to click OK/apply to see changes. 

Labelling points 

The Labels tab shows a variety of labelling options such as font type and size, whether you want 

a halo around the label (buffer) which is useful when the labels are over a coloured background. 

The Formatting section allows you to specify multi-line labels and word wrap options. The 

Placement options allow you to test different ways to display your labels.  
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Note that to manually move individual labels, use the “Move Label or Diagram” option in the 

labelling toolbar. 

 

There are three placement options, and it is suggested to test these options for each application. 

The “Cartographic” option (points only) will move labels to suit the display. If you need a “halo” 

around the labels, use the Buffer option. To rotate all the text labels, use the Labels > Placement 

> Offset from point > Rotation option. This option is useful for labelling drill holes along grid lines.  
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Multi-attribute labels can be created using the expression editor. Note the “Output Preview” in the 

lower left of the dialog box which shows how the labelling will appear. 
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QGIS In Mineral Exploration   

 P a g e  | 76 
 

An example is shown below displaying the structure type with strike and dip.  

 

 

In the Layer Properties > Label there is an option to add “call-outs” where lines can be 

automatically created to join a point to a label. 
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Labelling drill holes with collar names and depths of holes can be achieved using the expression 

editor in the labelling tab. Note to check the Preview to ensure your syntax is correct.  

"Drill_Hole" || ' - ' || maximum (  (  "Hole_Depth") ,group_by:= "Drill_Hole" ) || ' m'  

 

 

 

7.9 Joining Spatial and Non-Spatial Data 

 

Joins are done via the Layer Properties dialog box. Open both the spatial file (i.e. the layer that is 

spatially located) and the non-spatial file (without spatial reference). The non-spatial file can be 

opened by the spreadsheet or text file import and with “No geometry” selected. The non -spatial 

layer will appear as a spreadsheet icon in the Layer properties panel. Select the spatial layer in 

the Layers panel you wish to join, open its Layer Properties > Join tab, press the green plus to 

add a new join, select the join fields (which must have data in common in both layers to allow it to 

join).  

The example below (Bow 100k map sheet) shows the join of the geological polygons with the 

geological descriptions (from an Excel file) for each of the geological codes for the po lygons. 

Individual fields can be selected for the join using the “Choose which fields are joined”. Select the 

“Custom field name prefix” and change it to a short abbreviation, remembering that shape files 

can only have a maximum field name size of 10 characters and this may cause problems later as 

field names may have been truncated. 
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After clicking “Apply”, examine the join results by opening the layer attribute table and ensuring 

the join has been successful.  

 

To make this a permanent join, use the “Save As” option by right-clicking on the layer name in the 

layers panel, and saving the file as a new shapefile layer. If you do not save this joined file, the 

join will not be permanent, as it is a virtual join only. You may also need to copy the polygon styles 
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from the original shape file to the new spatial file. To do this, right click on the layer name, go to 

Styles > copy styles > all style categories, then right click on the layer where you want to appy 

these styles, and paste > paste styles > all style categories. Remember to use the layer properties 

> Style tab and “save as default” to create a qml file that will automatically apply these styles when 

the file is re-opened. 

 

7.10 Geological Legends 

Geological legends in QGIS can be created but the program really needs a plugin to create a 

geology specific style of legend. Geologists use QGIS very differently to the majority of QGIS 

users and this would need to be pushed by the geoscience user community . Detailed geological 

information, e.g., formation names, can be imported into the legend using the Legend tab in the 

Layer Properties > Legend tab. Note that you may have to join the geological information to the 

geological polygons, as in the case of GSWA geological data, before you create a more detailed 

legend. 

 

In the window above, the label text has been selected using the “Set Labels from Expression” 

which then opens the expression builder window (below). 
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The legend will be displayed in the print layout window as shown below.  

 

 

Work is in progress to automatically assign geological patterns and descriptions from the GSWA 

polygon colouring information and pattern fills with the vector data for their digital maps.  

Adding user defined polygon colours 

If the geological polygon layer is imported from ESRI or MapInfo, the styling information is lost. 

Some suppliers of this data create qml or qlr files to accompany the shp files to allow custom 

colouring. To apply custom colours, it is necessary to do a categorical style on the polygon l ayer 

based on geological code or name, and then use the rule-based renderer to edit the colour 

information and polygon name for each geological unit.  
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Don’t forget to save as “default” to save the styling information!  
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7.11 Importing and Exporting GPS Data 

To import points and tracks from a gpx file collected using a GPS unit, use the Data Source 

Manager and the GPS tab, select the gpx file to upload and the data type (tracks or waypoints). 

After you have imported the point or track file to QGIS, save it as a shape file to enable editing of 

this data. 

 

To send data to your GPS device, use the POI (“point of interest”) plug-in. The plug-in allows you 

to select the layer you want to upload, the column containing the point names (or ids ) and an 

optional comments column (up to 254 characters). The plug-in creates a gpx file which can then 

be easily uploaded to your gps via a direct file transfer or GPSBabel (for older models).  The 

projection of the layer does not need to be in WGS84. Select the folder where you want the file to 

go, select the layer to export as a gpx, enter the filename in the “Default Category Name” box, 

then select the column to be used as the “POI” name. The “Optional Description Column” can be 

used to upload other columns such as a site description into the “Comment” and “Description” 

fields of the gpx file. 
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If you have problems with the gpx files, you may have to download the free “GPSBabel” utility 

(https://www.gpsbabel.org/) or purchase the GPS Utilities program (http://www.gpsu.co.uk/, 

US$60). The GPS Utilities program has a vast array for GPS formats that you can read or write. 

After you imported the GPX file into QGIS, remember to save the GPS layer as a shp file to allow 

for editing of the data. 

Note that when uploading points to a GPS via a gpx file, you may need to save the shape file in a 

WGS84 (Lat/Long) projection and add two new text fields for “Name” and Desc”. Note that to 

include a long description in the DESC (Description) field, such as an outcrop observation, ensure 

you make the string length to be 254 characters. Note that some GPS units will only display a 

certain number of characters, for example the Garmin etrex Vista C only displays 30 of the 254 

characters. Copy your point id’s from your location reference column into the “Name” field us ing 

the attribute table. Do the same to copy any comments into the “Desc” field. Save the shape files 

as a gpx file with GPX USE EXTENSION “YES” before uploading to the GPS. The point id’s will 

then appear as your waypoint names and the comments will appear in the notes section. 

https://www.gpsbabel.org/
http://www.gpsu.co.uk/
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Open GPSBabel and select the gpx file to be uploaded, check Device “Garmin serial/usb” and 

device name “usb”. 
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The lower window will confirm if the upload has been successful.  

A live link to your GPS can be accessed via the View > Panels > GPS Information panel with 

various connection, display, and digitising options. This allows the user to have QGIS running and 

a live map link via the gps. 

 

7.12 Using the GSWA WAROX and WAMINES data 

The WAROX (2019 edition) database contains the GSWA field locations, sample sites, outcrop 

photos and petrography reports. The Microsoft Access database supplied by the GSWA contains 

pre-defined queries to make it easier to access the data. The query “qry_detailed” allows the user 

to extract the GSWA observation sites and “qry_summary” indicates if photographs have been 

taken of outcrops. The query “qry_photos” contains the photo information. Note the location of the 

photos is in the LocationID field and needs to be joined to the “qry_summary” to assign a location 

to each photo. To import this data into QGIS, export the query as a csv (qry_detailed.csv), 

ensuring you select the first row as field names, and then import this into QGIS via the CSV import 

option. Change the projection to GDA94 from the default WGS84. The Access queries can also 

be modified to allow the extraction of observation sites with photos only.  

In QGIS, open the layers attribute table, make editable and add another column (called something 

like “SourceFile”) of type string (text) with width of 100 characters. Save this update. This 

“SourceFile” column will hold the file location and photo number that will allow QGIS to display the 

photo for this location. The next step will concatenate the directory path and photo  file name into 

the “SourceFile” column. 

Click in the column selector to select the “SourceFile” column and then enter the following 

expression in the expression editor “concat(‘directory location’||”SourceFile”) substituting the 

directory location to point to where you have saved the WAROX photos. Note you need to change 

the default back slash (\) to a forward slash (/) in the directory path or you will get “?” replacing 

the back slashes. Save the file. 

 

You may want to Categorise the points into those with and without photos using a “Rule based” 

styling using photo SourceFile is Not Null for points with photos (meaning there is a photo link), 

and no photo when SourceFile is Null (no photo link). I have used a photo icon to indicate if there 

is a photo available at a particular location. 

Use the methods above to  display photos linked to that site. The Action properties for the layer 

can also be used to display photos. An example below shows the WAROX points displayed to 

indicate whether a photo was available at that location. 
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A similar process can be used to display linked petrographic reports and photos in the WAMINES 

database. See below an example from the WAMINES database. To display pdf files, you will need 

to add the pdf display program in the “Configure External Applications” tab. 

 

 

PDF files can also be displayed via the Action tab, add the cmd /c command to the action text.  
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7.13 Creating and converting Local (Non-Earth) Grids to Real World Coordinates 

The Geoscience plug-in allow you to create a custom CRS. For this you will need at least three 

points in both coordinate systems, better to have four and enter 0 for any Z values. This plug -in 

will create a WKT (“Well Known Text”) file that can be used to create a custom CRS in QGIS under 

the Settings > Custom Projections tab. 

There is no easy way to convert non-earth coordinates but there is a way by using the v.transform 

algorithm. The algorithm requires an x, y coordinate for the grid origin and an optional rotation 

amount. This data should be available from the mine surveyor or can be calculated. The author 

uses a small python program that uses 2 common sets of points to calculate a grid origin and 

rotation amount. The workflow below is for point data and within one UTM zone in metre 

coordinates only. If you would like a copy of this python code, please contact me. 
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Using a new project workspace, change project projection to “no projection” then open the local 

grid file using the local coordinates (e.g. drill holes in local coordinates). Check that the local 

coordinates in the map window look correct. 

Run the v.transform algorithm with the points in local grid coordinates. To find this algorithm 

display the Processing Toolbox in the RHS of the map window, type v.tr in the search box and 

the v.transform algorithm should now be displayed. Double click on it to open the v.transform 

dialog box. Use the parameters for x, y and rotation.  

Allocate the new projection to the points by firstly, setting the projection of the transformed 

layer to your desired UTM projection (very important to do this first) via the Layer Properties > 

Source tab, then change the project projection to your UTM projection. Close the original local 

coordinates file and zoom to the extent of the new transformed layer to check the transformation 

was successful.  

This will produce a transformed (virtual) layer which will need to be “Exported As” to save the file 

permanently. 

 

7.14 Creating a Grid Layout 

A regular grid of points can be created via a table of coordinates or using the “Regular Points” 

algorithm. Other create grid options are available in the Processing Toolbox, but these two 

methods are the simplest. 

To create a grid, from a table of coordinates, use the “Create points from Table” algorithm located 

in the Processing Toolbox under the Vector Creation list. Input the table that contains the 

coordinates, select the X and Y coordinate fields, with optional Z and M fields as well, check the 

CRS and run. The algorithm will create a series of points with id’s  only. Use the attribute table to 

add Easting and Northing fields if desired to attach the point coordinates.  

To create a grid of points using the map window, use the “Regular Points” algorithm in the Vector 

Creation list. The extent of the grid can be entered manually or defined by the map window extent. 

Set the grid spacing and check the CRS and run. The resulting grid can be rotated (using the 

Vector Geometry > Rotate algorithm) or the “Rotate Feature” on the map window icons (next to 

the “Move Points” icon). Both methods allow the user to select the point for rotation and the amount 

of rotation. 

If you want to create non-square or hexagonal grids, for example, use the “Create Grid” option 

under the Vector Creation options. 

 

7.15 GeoPackages 

 

The following is from the Open Geospatial Consortium (OGC) website 
(https://www.geopackage.org/).  

GeoPackage is an open, standards-based, platform-independent, portable, self-describing, 
compact format for transferring geospatial information.  

The GeoPackage Encoding Standard describes a set of conventions for storing the following within an 
SQLite database:  

https://www.geopackage.org/


QGIS In Mineral Exploration   

 P a g e  | 90 
 

• vector features  

• tile matrix sets of imagery and raster maps at various scales  

• attributes (non-spatial data)  

• extensions  

To be clear, a GeoPackage is the SQLite container and the GeoPackage Encoding Standard governs 
the rules and requirements of content stored in a GeoPackage container. The GeoPackage standard 
defines the schema for a GeoPackage, including table definitions, integrity assertions, format 
limitations, and content constraints. The required and supported content of a GeoPackage is entirely 
defined in the standard. These capabilities are built on a common base and the extension mechanism 
provides implementors a way to include additional functionality in their GeoPackages.  

What all this means is that you can create a Geopackage with vector data containing point, line 

and polygon data with their respective stylings, and also include raster data files.  

Field names are not restricted to 10 characters, as is the case with shape files.  

GeoPackages can be used to transfer complete projects with all the data and display attributes – 

see the end of this section for details. 

When digitising into a Geopackage file, the id field is automatically incremented. The data is 

spatially indexed so panning and window refreshes are much faster.  

Geopackages have a .gpkg file extension. 

To create a new blank GeoPackage, use the Layers > Add New Layer and select Geopackage. 

The following dialog box will appear. 
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The database name will be the new Geopackage name and make sure you selected the three dots 

to the right of the entry field to ensure you know where it will be saved. The table name will be the 

layer within the Geopackage. Ensure you select the correct geometry for the layer and the correct 

CRS of the data. Add your required fields for the table/layer and press OK to create a Geopackage. 
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Once a Geopackage has been created, shape files in the layers panels can be selected and 

dragged into the browser panel and added to the Geopackage file  by overlying the layer on the 

Geopackage name (a small plus symbol will be displayed when overlayed in the correct place) . 
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Geopackages can also be used to store complete projects. Currently this requires three steps.  

Firstly, use the Processing Toolbox > Database > Package Layers algorithm to package all the 

vector layers into a Geopackage – this algorithm only saves the vector layers. Ensure you tick 

the “Save layer styles into GeoPackage” (only available in versions 3.8 and higher).  
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The next step is to drag the raster layers into the new GeoPackage, then close the original 

layers. 

The last step is to re-open them using the GeoPackaged files. Reorder the layers as required 

and save the project into the same folder as the GeoPackage.  

You will then have a GeoPackage file ***.gpkg and an associated project file (***.qgz) which 

when moved together will be the complete project data package.  

Note that Geopackages can only be edited by single-user at a time. 
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8: DISPLAYING GEOCHEMICAL DATA 

 

8.1 Importing and Styling Geochemical Assay Points 

 

Geochemical data is usually in the form of an excel spreadsheet or as a text file. Open the file in 

QGIS via the “Spreadsheet Layers” or CSV file open options depending upon the format of your 

data. See section 6 above for opening spreadsheet and csv files, and the potential use of CSV 

format files (*.csvt) for large complicated csv files. If you have problems importing large csv files 

exported from Excel, save the file as a tab-delimited text file and import this into QGIS. 

IoGAS has created a QGIS plugin for its export files and can be downloaded from the ioGAS 

website (https://reflexnow.com/download-qgis-plugin-for-imdex-iogas/). This provides a live link 

between QGIS and ioGAS. 

When loading your data, ensure the data has been loaded into QGIS as the correct field type, i.e. 

as a number, not as a string (text) field. This can be checked using the layer’s Layer Properties > 

Fields tab. 

When the data has been imported into QGIS, make sure you check the correct coordinate system 

has been selected. 

Use the View > Statistical Summary option to display the statistics for a particular field. This helps 

to identify potential problems with the data such as negative values representing below detection 

limit data. 

Geochemical point data can be displayed as points and can be coloured or sized according to 

value.  

 

To filter out bad data, use the “feature filter” in the Source tab of the Layer Properties to filter out 

all the negative numbers (below detection or not assayed) – see the following image as an 

example for the Cr data. 

https://reflexnow.com/download-qgis-plugin-for-imdex-iogas/
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Use the query builder, as shown below. Note that this has only been done for Cr values in this 

example. 

 

This is important for geochemical data so the negative values do not influence the statistics of the 

data. 

Univariate statistics can be calculated using the View > Statistical Summary panel. This opens a 

panel under the browser panel, where you can select the layer and data field for which field you 



QGIS In Mineral Exploration   

 P a g e  | 97 
 

want to calculate statistics. The mean, standard deviation, first quantile, third quantile and the 

Inter Quartile Range (IQR) are among some of the calculated results.  

To examine the statistics of the data, use the View > Statistics Panel and select the field to be 

queried. 

 

 

In this example note that the first and third quantiles are 170 and 390 ppm Cr with an IQR (inter 

quartile range) of 220. Geochemists would say that any values over 720 ppm Cr (Q3 + (1.5 * IQR) 

are anomalous. 

To colourise your data, use the Layer Properties > Style tab to select the way you want the data 

displayed. The simplest way is to use the “Graduated” option and colour the point values. Note 

that this works on numeric values only. Select the column you wish to colour the points by and the 

desired colour ramp and hit the “Classify” button. Under the display window, you can also select 
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the way the points are coloured. You can use a variety of methods. You can also manually edit 

the ranges in the display window. 

To colour the geochemical data by assay value, select the Style tab in the layer properties panel. 

Select the Graduated option in the top drop-down box. Select “Cr” as the field to be displayed. 

Select a suitable “colour ramp”, select Mode “Quantile (Equal Count)”, change Classes to 8, hit 

“Classify” (if you forget to hit Classify you will not any colours!). You will note that the boundary 

between the second and third quantile is 170 ppm (Q1) and the boundary between the sixth and 

seventh range is 390 ppm (Q3). Other display modes may be more applicable, and this will depend 

upon your data and how you want to display the data.  

 

 

 

The top two classes are below 170 ppm (25th percentile) and the bottom two classes are greater 

than 390 ppm (75th percentile). You can manually edit the second last range so that its upper value 

is 720 ppm (anomaly threshold) and it will automatically update the eighth data range.  
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In the figure above I have selected the >720 ppm and enlarged the symbol.  

 

Other options are available for the display of the data – see the “Mode” drop-down box. 

Note you can vary the displayed number of decimal places in the legend by using the “Precision” 

option in the dialog box. 
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The drawing order can be varied so that all the high values are plotted on top. To do this scroll 

down the Symbology dialog box to the “Layer Rendering” option, turn on the “Control feature 

rendering order”, then click the “sort” icon on the right-hand side. 
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Select field to use for the ordering and whether you ascending or descending order. 

 

 

Points can also be classified by size. Click in the Symbol box (where it says “change”) to bring up 

the symbol selector window. Highlight the “Marker” layer in the top left, then click on the far -right 

hand side of the Size options where there is a little square box with a down arrow. This is the 

“Data Driven Override” button. Click on this and scroll down to “Size Assistant” where you can 

select the symbol size by the field “Cr”. Select the field to use for the size, then refresh so that 

QGIS can calculate the data range in that field. Select OK to apply. Close the layer properties 

window. 
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8.2 Gridding Surface Geochemical Data 

 

To create a grid of the geochemical data, zoom to an area of data that you want to grid and open 

the Processing Toolbox (right hand side window) > SAGA > Raster Creation Tools > Multilevel b -

spline. Select the field to grid and click select and enter a file name (if you want  a permanent file 

output) and location to where you want to write the grid file. It is important to make sure QGIS 

can write to the folder (not the default Program Files folder), otherwise the operation will 

fail. Note there are many gridding options available in QGIS, this is one example.  

Zoom in to a subset of the data, as shown in the figure below. 
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To limit the area over which the grid will be calculated, use the canvas extent for the “Output 

extent” (click on the … to see the extent options). 



QGIS In Mineral Exploration   

 P a g e  | 106 
 

 

 

The default grid colouring is greyscale. To add colour to the grid, open the Layer Property > Style 

tab and select pseudocolour as the render type. If you can’t see the desired colour ramp, scroll to 

the bottom of the colour ramp display box and select “New Colour Ramp”, then Colour Ramp Type 

“cty-city”. A large range of colour ramps can then be selected.  
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A common ramp to use is the QGIS > grass “bcyr” colour ramp. Save this as a standard gradient 

(lower left-hand tick box) and save “Save Color Ramp” with a suitable name (e.g. Default Colour 

Ramp). 
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There are a variety of gridding option in QGIS (see menu item raster > interpolation) but I have 

found the SAGA gridding tools, which includes b-spline, inverse distance and kriging, to be the 

best for geochemical data. Note that the spline method will not  be exact and will overshoot and 

undershoot some of the point values. Check a few different methods to find one that suits you 

best. 
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8.3 Contouring Surface Geochemical Data 

 

To create contours of the data, use the Raster > Extraction > Contour menu item.  

 

In this example I have used a contour interval of 100 ppm and called the contour field name 

“ppm_Cr”. This can be saved as a temporary file to check the results before saving a final version.  



QGIS In Mineral Exploration   

 P a g e  | 110 
 

 

 

To emphasise significant value contours, like every 500 ppm for example, use the Data Driven 

Override box to the right of the “Width” option in the Layer Styling panel. Open the edit option to 

bring up the Expression String Builder. 

 

The code is saying if the contour value (ppm_Cr) is divisible by 500 with a zero remainder, i.e  is 

a multiple of 500, then use a line thickness of 0.6 mm. The % symbol returns the remainder after 

a division. If the number is not a multiple of 500, then test if it is a multiple of 100. If it is, then use 

a line thickness of 0.3, otherwise use a line thickness of 0.15. 
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We can now annotate the contour lines using the Layer Styling panel and select the Label tab and 

choose the Single Labels option and the ppm_Cr field for the value to be plotted.  

 

The default view is shown above. To tidy this up change the font size (on the first tab “abc”) to 8, 

choose a white buffer of 0.8 (third tab along) and the placement (on the 8 th tab, four directional 

arrow), set to Mode Parallel, tick on “On Line, uncheck the “Above Line” setting.  
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This looks a lot better and can be fine-tuned depending on your data. 
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9: GEOPHYSICAL DATA IMPORT AND DISPLAY 

9.1 Data Import 

Geophysical data usually comes as located data files (text) or grid files. QGIS can read many grid 

formats with *.ers, and *.tif (geotiff) files the most common, and these can be loaded by dragging 

the file name from the Browser Panel into the map window. Note that Geosoft *.grd files require 

conversion to *.ers files via their free viewer Oasis Montaj program (available from 

www.geosoft.com). Note that some raster image files have to be opened via the Data Source 

manager > Raster options, e.g., BIL files. 

When opening located data text files, remember that shape files can only have  field names up to 

10 characters in length. If your text files have longer field names, then it is suggested you use a 

free text editor like Notepad++ (https://notepad-plus-plus.org/) or ATOM (https://atom.io/, for large 

files) to modify the field names.  

Alternatively, after you have imported the located data, you can save it as a Geopackage file which 

does not have the 10-character field length restriction. 

There are numerous methods to create grids of located data. I typically remove the tie lines by 

using a filter based on the Line number before I create the grid. One method I have found useful 

is to use the SAGA > Raster creation tools and use the “Multilevel b-spline interpolation” option. 

 

 

 

http://www.geosoft.com/
https://notepad-plus-plus.org/
https://atom.io/
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Grid files are treated as raster files and are usually displayed as greyscale by default. To change 

the display, open the layer properties dialog and select “Style”. A var iety of options are available 

including changing the colour ramps, colour stretch and display value limits. For a coloured image, 

use the Render Type > “Singleband Pseudocolour” option.  

You may also want to create a polygon file as an outline of the area to be gridded. This can then 

be used to clip the grid to the data. 

 

 

9.2 Colour Ramps 

 

Additional colour ramps are available by clicking on the down arrow to the right of the “Color  

ramp” dialog box and selecting “Create New Color Ramp…”, select “Catalog: cpt-cty” from the 

drop-down box to display a variety of available colour ramps.  

Colour ramps have also been developed by the Centre for Exploration Targeting (CET) in Perth 

that have better colour perception. These can be reviewed and downloaded from here 

“https://peterkovesi.com/projects/colourmaps/”. Download the QGIS xml file and import via the 

Options > Style manager dialog box. My preference is to use the CET-R1 to CET-R3 ramps 

which are rainbow style colour ramps and they have the blue to magenta colour ranges which 

work well for shading magnetic images for example.  

 

https://peterkovesi.com/projects/colourmaps/
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The “bcry” is a also good option for colouring geophysical data grids. Select the “Save as 

standard gradient” tick box in the lower left of the dialog box, then the Save Color Ramp. 

 

Save the color ramp with a name, e.g. default colour ramp, and “Add to favorites” so it shows up 

on your quick colour ramp select options. 
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Note that you can use the information icon to examine the values of a pixel or grid location. If the 

value is not displayed in the Identify panel, try minimising the left-hand side column, as sometimes 

the column width is too wide for the panel to display the cell value on the right-hand side. 

 

If you open a grid file and have difficulties displaying the data, e.g. with 1VD magnetic images, 

zoom in to a small area of the grid and then “Stretch to Current Extent” (available as a right click 

on the layer name in the Layers panel) to stretch the data to something visible. 

When a continuous raster layer is added to the map window, the layer panel displays the colour 

range.  
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The display of the data labels in the Layers panel and the legend can be controlled using the 

“Legend Settings” options in the lower right-hand side of the Symbology tab. 

 

 

New in version 3.18 is to have a continuous colour bar in the Layers panel and the legend for print 

layouts. 
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In the Layer Properties > Symbology tab, select the “Legend Settings button to change the way 

the colour stretch is displayed and the size and orientation of the colour bar for your print layout.  

 

 

Example of continuous colour bar in the Layers panel.  
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9.4 Extracting Point Data from a GRID 

If you need to extract a value from a grid (raster) file e.g., drill hole collar elevations from a DEM, 

there are at least two options. 

The first option is to use an expression in the layer expression editor dialog to populate the desired 

field (for example using the create new field in the attribute table) as follows; 

Raster_value(‘dem layer’,band,make_point($x,$y)) This expression looks at the dem layer or grid 

name, the band in the grid with the data to be extracted, and creates a point.  

 

The other method is to use the “Sample Raster Values” algorithm or the “Point Sampling Tool” 

plug-in. 

To find point values in a raster grid, use the Processing Toolbox > Raster Analysis > Sample 

Raster Values algorithm. This creates a new layer which can then be used to overwrite the original 

layer with the new values. 
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The Point Sampling plug-in tool can also be used to sample points in a grid, e.g. drill hole collar 

elevations using a digital elevation grid. The output creates a separate file with the resulting 

values. The point and grid layers need to be in the same projection. The tool is found under the 

Plugin > Analysis > Point Sampling Tool. 
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Select the layer containing the points to be used for the data extraction (drill holes), then select 

the fields to be exported with the points (Hole number), and then select the layer with the elevation 

data (e.g. dem-9s:Band 1). This will then create a file with hole number and elevation. This will 

then need to be joined to the drill collar file for example. I find it quicker to use the v.what.rast 

algorithm above, as this automatically undated the data field. 

 

9.5 Custom Data Stretch 

 

The Raster toolbar has a collection of basic display options to change how the image is displayed.  

Images can be stretched to the entire image or window extent. See the mouse over for how these 

icons work. 

 

Display settings can also be selected in the Symbology tab of the Layer Properties.  
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9.6 Profiling Gridded Data 

 

To obtain a profile across any gridded data, use the “Profile” plugin. Open the Profile plugin 

(usually on the menu bar) and use the “Add Layer” button to add the layer from where you want 

the values extracted. Draw a line using one click to start and a double click to complete the line.  

The resulting profile values can by copied to the clipboard (under the Table tab)  for use in 

programs like Excel. 
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9.7 Creating Stacked Profiles and Colour Bars 

 

Creating “stacked profiles” of data, especially magnetic data is important for the identification of 

small discrete features in wide spaced aeromagnetic data. One example is in the search for 

kimberlite pipes in regional (>300 m) spaced line data.  

This algorithm has been created by Benoit at GeoProcessing 

(http://www.geoproc.com/be/plugins.xml) in South Africa and is part of their “GeoProc” toolset. 

The stacked profile tool allows the user to import located line data to plot stacked profiles of the 

data. It is important that the located data is in "point" format not multi -point data format.  

9.8 First and Second Vertical Derivatives 

First vertical derivative images can be created using the EnMap Box plugin and can be 

downloaded from this link (https://www.enmap.org/enmapbox.html). This plugin has been 

designed to cater for a new satellite that was launched in 2022 and has a large variety of tools 

for remote sensing data including filtering. 

 

https://www.enmap.org/enmapbox.html


QGIS In Mineral Exploration   

 P a g e  | 124 
 

 

When the plugin is installed it puts and additional link in the Processing Toolbox.  
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The Spatial Prewitt filter creates a first vertical derivative (1vd) image, the Spatial Laplace filter 

creates a second vertical derivative (2vd) image and the Spatial Gaussian Gradient Magnitude 

filter creates a type of analytical signal image. 

Clipping of the resultant images may be required and set the background with no data  to zero or 

-99999 so it can be set to transparent. 

Note also when creating images for use in MapInfo, create ERMapper ers grid files.  
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10: 3D IMAGE DISPLAY 

QGIS v3 now has a 3D view capability built in as a standard part of the program (3d Map View) or 

by using the QGIS2threejs plugin. The QGIS2threejs is the best option at this time for viewing 

geological data in 3D. Downhole drill hole traces can be displayed if the 3D coordinates have been 

calculated. 

10.1 3D Map View 

The layers require to be projected, i.e. not a geographic projection, lat/long, and they should all 

be in the same projection.  

To run the 3D view, place the layers into the map window with the DEM layer at the bottom of the 

layer stack. Go to the View > New 3D Map View menu item and create a 3D map window. Resize 

the window to suit and select the little spanner symbol to open-up the options dialog. 
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Select the layer to be used as the “Elevation”, set the vertical exaggeration and press OK. Use 

the hand icon to move the display in the window. To tilt the display to see the 3D effect, hold the 

shift key and drag the mouse towards down. With the shift key depressed you can also rotate the 

image. Scroll speed will be dependant upon the size of your grid files and the speed of your PC.  

 

Any image displayed in the map window can be used for 3D display.  
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10.2 QGIS2Threejs Plugin 

This plugin is more flexible than the 3D map view at the present stage of its development for 

geological application. The layers require to be projected, i.e. not a geographic lat/long projection, 

and they should all be in the same projection. If you have data in 3D, i.e. with x, y and z 

coordinates, then this plugin can display the data. If you get weird effects, you may have a lat/long 

layer in the map window which may be causing problems. Close any lat/long layers and re-run the 

plugin. 

To use this plugin, load a DEM or any type of grid file over which you would like to drape data. 

For example you may wish to drape a satellite image or geological map over a digital terrain model  

 

Make sure the grid is on the bottom, with the layers to be draped on top of the DEM/grid layer. 

Run the QGIS2Threejs plugin and select the DEM layer.  

Vertical exaggeration can be changed using the Scene > World Settings dialog box.  
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If you have vector data with a z (e.g. RL or elevation data) then right click on the vector layer name 

in the QGIS2Threejs window and select the z value to use in the “Z Coordinate” options. Downhole 

drill hole data can be plotted using this method.  
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The image below shows a Google Earth image, draped over a SRTM digital terrain model, with a 

vector file of surface samples and drill hole sampling.  
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11: REMOTE SENSING 

The availability of free satellite and other remote sensing data has created unique opportunities 

for the display of this data to assist geological interpretation and analysis. QGIS can display the 

normal satellite images, but it also has a powerful plugin, the Semi-Automatic Classification (SCP) 

plug-in, which can be used to source, select, download and process satellite imagery.  Video 

tutorials are available on the web (https://www.youtube.com/watch?v=GFrDgQ6Nzqs) and cover 

a variety of remote sensing applications including land cover classification.  

To download ASTER and Landsat data, you are required to register (free) at the USGS 

EarthExplorer portal. These registration details will be required to be entered on the SCP 

download/login window. Sentinel data download requires (free) registration at the ESA Sentinel 

data access portal. Note that it might take three or four days for your registration at ESA to become 

active. Recently, the search times on the ESA site via the SCP plugin have been very slow and it 

has been my experience lately that the USGS EarthExplorer portal is the fastest way to select and 

download ASTER data. 

11.1 Using the Semi Automatic Classification Plugin 

 

Selection, downloading and processing of satellite remote sensing data can be achieved using 

the Semi Automatic Classification Plugin (SCP) written by Luca Congedo 

(https://fromgistors.blogspot.com/p/semi-automatic-classification-plugin.html). After installing the 

plugin you can open the plugin via the main menu bar. Note the plugin automatically adds panels 

and toolbars which I normally close to free up window space.  

 

The main SCP window shows tabs for downloading data, as well as a variety of other pre and post 

processing options, band calculations and tools for land cover classificat ion. 

To download data you need to register with the USGS via their EarthExplorer portal (free 

registration, http://earthexplorer.usgs.gov/) for ASTER and Landsat data and with the European 

Space Agency (ESA) via their Sentinel data access portal  

(https://scihub.copernicus.eu/dhus/#/home). Enter these login details into the relevant sections of 

the SCP Download Products > Login data tab. Make sure you click “Remember” so you don’t have 

https://www.youtube.com/watch?v=GFrDgQ6Nzqs
https://fromgistors.blogspot.com/p/semi-automatic-classification-plugin.html
http://earthexplorer.usgs.gov/
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to re-enter your login details each time. Note also that logins with ESA make take a couple of days 

to initialise. 

 

Once all the logins are complete, then you are ready to download data. Have the area that you 

wish to obtain data displayed in your QGIS map window as we will create a search area directly 

into this window. Click on the Search tab of the Download Products window. 
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The required product can be selected via the “Products” dropdown list. To select a search area, 

click on the orange-red cross in the top RHS of the window, then left click the top left hand side 

of the map area, then right click on the lower right hand side to set your search area. This will then 

populate the search area parameters. 

 

You can further refine your data search by entering for example a Sentinel 2 tile number into the 

“Filter” window to speed up searching and ensuring you only download the required tiles. You can 

select the maximum allowable cloud cover and any date ranges. Note that for ASTER data only 

download data prior to 1st April 2008 as the SWIR became non-operational after that date. 

Once you have selected the search area, open the “Preprocessing’ window.  
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The Preprocessing window allows SCP to do atmospheric and other adjustments to the source 

satellite data after download, e.g. DOS 1 atmospheric correction on L1C corrected Sentinel 2 data. 

Note that preprocessing will only occur if the “Preprocess Images” check box is tic ked in the 

Download window. If you download Sentinel 2 L2A data, the atmospheric corrections have already 

been applied. Note also the other check boxes to limit what gets downloaded and what is displayed 

in the map window. 

Once you have set your search parameters, click the “Find” icon. 

 

SCP will search the data for tiles fitting the search parameters.  The time to retrieve the data will 

depend upon internet speed. If you get a time-out error or cannot connect type message, check 

your login details. 
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A list of selected tiles will be shown in the ProductID window and each item can be highlighted 

and viewed in the RHS window. Note that you can now choose between Sentinel 2 L1C and L2A 

processing levels. The L2A data has been corrected for atmospheric effects. Check that the scene 

is suitable, e.g. no cloud over your area of interest, then click the icon “Display preview of 

highlighted images in map”. This will then download a low-resolution full scene image into your 

map window to ensure it covers the correct area. 

 

To download this data, return to the Download products window and make sure the “Download” 

“Only if preview in Layers” is checked on. This will ensure only those layers you have in the map 

window will be downloaded. If all OK, click the run button and save it to the required location. The 

download and pre-processing may take some time, 10-20 minutes, and it is advised not to use 

QGIS during this time as it may crash the process. Other programs on your PC may be used.  

The download process will entail downloading all the band data, then running the selected 

corrections, before displaying the final set of image bands into your map window. These bands 

can then be used to create RGB images and allow band ratios to be calculated.  

Note that you can create a multiband tiff file that holds all the band data in one tiff file. This can 

be created via the Raster > Miscellaneous > Build Virtual Raster option, and by selecting all the 

bands and then using the “Highest” resolution, so that the pixel sizes of all the bands will be the 

same (“pansharpened to the smallest pixel size). Processing of this multiband file is now possible 

in the SCP or Orfeo Tool Box plugins. 

The SCP Plugin also allows the user to do a multitude of other task including Principal 

Components Analysis (PCA). Note that to use PCA all the images must have the same pixel size, 

and this may require “resampling” of the image (use the Processing Toolbox > SAGA > Raster 

Tools > Resampling algorithm). 
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11.2 ASTER Data 

Details of the ASTER (Advance Spaceborne Thermal Emission and Reflection Radiometer) 

scanner bands are shown in the figure below (from Abrams and Hook 2016). 

ASTER data is now freely available worldwide but note that the SWIR sensor (bands 4 to 9) 

became inoperable on 1st April 2008, and therefore only data acquired before this time will 

be suitable for mineral mapping. 

 

 

An example of ASTER band combinations using ratio 4/7 (red), 4/3 (green) and 2/1 (blue)around 

the Argyle mine area. 

ASTER bands and band ratios for geological applications are shown in the tables below (from 

ASTERDataProcessing_GA7833.pdf available from Geoscience Australia).  
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Band rations are easily calculated in the SCP plug-in. My personal experience for using the 

ASTER data in Western Australia and Peru, is that the discrimination ratios using ratio 4/7 (red), 

4/3 (green) and 2/1 (blue) works well in most situations. The AlOH minerals/Advanced argillic 

alteration combination and the Alunite-Kaolinite-Pyrophyllite image also works well for detecting 

alteration associated with porphyry copper mineralisation.  
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Other possibly useful ASTER band calculations and combinations are listed below. 

Abrams Ratio – 5/7, 4/5 and 3/1 in RGB 

Sabin Ration – 5/7, 3/1 and 3/5 in RGB 
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Mineral Indices of Ninomiya (2004) 

 OH Minerals Index – (Band 7/ Band 6) * (Band 4/Band 6) 

 Kaolinite Index – 4/5 * 8/6 

 Alunite Index – 7/5 * 7/8 

 Calcite Index – 6/8 * 9/8 

Porphyry Alteration Index – 4, 6 and 8 and RGB (advanced argillic and phyllic alteration in pink to 

red colours) 

Alunite and kaolinite enhanced by 4/5 or 4/6 

Sericite – phyllic alteration enhanced by 5/6 

Propylitic alteration enhanced by 5/8 

 

Remember the resulting images may have artefacts caused by low sun angles, clouds, etc. 

so be cautious in using the data. Remote sensing vendors can undertake more advanced 

processing and interpretation of this data, and the rough processing described herein 

should be used with caution. 

 

11.3 Landsat Data 

 

Landsat 8 data is collected over 11 bands as illustrated below.  

 

Landsat 8 band combinations are usually bands 4, 3 and 2 in the R, G and B channels for an aerial 

photo type image, whereas the combination of bands 6, 4 and 2 typically enhances the geology. 

Band 8 is used to pan-sharpen the 30 m images to 15 m resolution. The SCP plug-in will 

automatically pan-sharpen the RGB images if this option is selected. 

A recent article by Ito et al (2022) uses a series of indices to analyse the geology in Landsat 

scenes as follows; 



QGIS In Mineral Exploration   

 P a g e  | 140 
 

Index Number Index name Formula 

1 Ferric iron 1 “redness” 4/2 

2 Ferric iron 2 (4/2)*((4+6)/5) 

3 Ferrous iron, coarse grained ferric iron (3+6)/(4+5) 

4 Clay, sulphate, mica, marble (6/7)/(5/4) 

5 Iron sulphate (2/1)-(5/4) 

 

11.4 Sentinel 2 Data 

 

The Sentinel 2 satellites are designed for earth observation and the figure below illustrates the 

comparison with the other satellite data bands (from van der Meer et al 2014). The Sentinel 

satellite constellation has been launched by the European Space Agency (ESA) and the derived 

data is available free of charge. See ESA website (https://sentinel.esa.int/web/sentinel/home) for 

more detail on the available data and data access. You need to register (free) on the Sentinel web 

site to be able to download the Sentinel data. 

 

When using Sentinel 2 data, it is recommended to use bands 4, 3 and 2 (for RGB) for the natural 

aerial photo type image and a combination of bands 12 or 11, 4 and 2 (for RGB) which can 

enhance the geology in a scene. Users should experiment with various band ratios to find which 

is the most suitable for their application.  

The following list of recommended band combinations is from the Sentinel education web page 

(https:/Sentinel-hub.com/develop/education).  

Natural Colour B4 (red), B3 (green), B2 (blue) 

Colour Infrared (vegetation) B8, B4, B3 

False Colour (Urban) B12, B11, B4 

Agriculture B11, B8, B2 

Vegetation Index (B8 – B4)/(B8 + B4) 

Moisture Index (B8A – B11)/(B8A + B11) 

Geology B12, B4, B2 

Bathymetric B4, B3, B1 

Atmospheric Penetration B12, B11, B8A 

SWIR B12, B8A, B4 

NDWI (B3 – B8)/(B3 + B8) 

SWIR-2 B2, B11, B12 

 

https://sentinel.esa.int/web/sentinel/home
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Another useful band combination for a “Regolith Ratio” image is 11/12 (red), 8A/12 (green) and 

8A/3 (blue) (from Mark Arundel). 

The figure below from van der Meer et al 2014 compares ASTER ratio mineral mapping to the 

equivalent bands in the Sentinel 2 data. 

 

 

 

11.5 Creating RGB Images 

 

There are two methods available to create a coloured image (“rgb”) of remote sensing or any 

other 3 band data set. We can use the Raster > Miscellaneous > Build Virtual Raster option or 

the “Virtual Raster Builder” plugin.  

The Raster option is shown below. 
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The Build Virtual Raster window will be displayed. Select the input layers as the ones to use for 

the RGB composite. Ensure you have the files in the correct order as it assigns the red channel 

to the top image, green to the middle image and blue to the lower image in the selection panel. 
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Select the “Highest” resolution to ensure you obtain the highest resolution possible and is si milar 

to “pansharpening” where the larger pixels will be resampled to match the smaller pixels. Press 

“Run in Background” and the composite colour image will be produced as a virtual image.  

To save this file permanently, you need to right-click on the “Virtual” file name and save as a 

“Rendered” RGB image and any chosen file format, usually GeoTiff. 
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To adjust the colour stretch, zoom into a part of the image where you want to see more detail and 

then use the Layer panel to right click on the RGB layer and select “Stretch using current extent”. 

This can be done multiple times until you get the desired result (see below for example).  

Alternatively, you can activate the “Raster Toolbar” and use the toolbar to adjust the colour stretch.  

 

The “Virtual” RGB image is currently only a temporary file. To create a permanent image, right 

click on the image layer in the Layers panel and select “Save As” Select the “Rendered Image” 

option, click the “Browse” and select the folder and required file name. Change  the coordinate 

system if required. When all is OK, click OK. It may take some time to create the tiff file depending 

upon the size of the image and the speed of your computer.  

The resulting RGB image can be saved via the Save Raster layer option.  
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Note there are options for saving as a geopackage or GeoTiff file and modifying the output 

projection Geopackage files are much more compact (smaller) than equivalent GeoTiff files.  

To merge adjacent satellite images/bands, initially try the Raster > Miscellaneous > Build Virtual 

Raster option. If this is unsuccessful, or creates large blanks between images, try the using the 

Processing Toolbox > SAGA > Raster tools > Mosaic raster layers. Option settings that have 

worked in merging adjacent ASTER scenes are Interpolation – “4 B-Spline”, Overlapping areas – 

“6 feathering”, Blending distance – “1000”, Match – “regression”, Cell size – “15” (or 30 m, 60 m, 

90 m - to match the relevant pixel sizes for the images being merged), Fit – “Cells” and save to a 

file. All other setting as default. 

If you have problems merging adjacent satellite images where you get edge effects between 

adjacent scenes, try downloading and installing SAGA (http://www.saga-gis.org/en/index.html). 

This a powerful and free GIS analysis program and has a good help file 

(https://sourceforge.net/projects/saga-gis/files/SAGA%20-

%20Documentation/SAGA%205%20User%20Guide/. The mosaicking option is found in the 

http://www.saga-gis.org/en/index.html
https://sourceforge.net/projects/saga-gis/files/SAGA%20-%20Documentation/SAGA%205%20User%20Guide/
https://sourceforge.net/projects/saga-gis/files/SAGA%20-%20Documentation/SAGA%205%20User%20Guide/
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Geoprocessing > Grid > Grid System > Mosaicking menu item. Use the Match option “match 

histograms of overlapping area”. 

 

11.6 Principal Components Analysis (PCA) 

Principal Components Analysis (PCA) can be undertaken using the Semi-Automatic 

Classification plugin or via the Orfeo Tool Box (https://www.orfeo-

toolbox.org/CookBook/QGISInterface.html). The input files for the PCA analysis require they 

have the same pixel size and may require resampling if necessary  (see Processing Toolbox > 

SAGA > Raster Tools > Resampling). The easiest way to ensure a common pixel size is to 

create a multiband raster using the Build Virtual Raster and selecting the “Highest” resolution 

option. 

If you need to resample the raster to a different cell/pixel size, ensure you check the cell size 

and “Fit” to cell, otherwise it will offset the resulting image. 

 

 

In the SCP plugin, create a Band Set using the Band Set tab. Press refresh to show what bands 

are available (in the Layers panel) then select the layers to be used for the band set – highlight 

the required bands, then click the plus symbol “Add band to band set”. This set of bands will be 

used in the PCA analysis. 
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Click on the Band Processing tab and select PCA. Check that the input band set is correct, 

select 3 components (required for an RGB colour image) and press Run. Select the target 

directory for the results to be saved. Note in the image above I have used the SWIR ASTER 

bands for the PCA analysis. 

 

This process will produce three PCA images, PCA1, PCA2 and PCA3. Use the Virtual Raster 

Builder plugin to produce the RGB image (as above). 
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12: MAP PRODUCTION 

12.1 Print Layout 

The Print Layout is the tool to produce maps for output. Various standard page sizes can be 

selected as well as creating custom sizes. Everything to do with the final map design is done in 

the print layout. If you lose tab views, click on the “Views” menu option in the layout window and 

scroll down to Panels to reselect them for display. 

To ensure you get true scale plots, it is important to have the main map projection in a metres 

projection (i.e. UTM) and not in a geographic lat/long projection. Problems may be created with 

the scale not being correct on the map output when the main map window is in a lat/long projection. 

12.2 Map Templates 

Templates can be constructed for use with a variety of map sheets sizes, e.g. A4, A3, A2 , A1 and 

A0 in either landscape or portrait orientation. Frames and title blocks are simply constructed  as 

rectangles and standard text boxes added into the rectangles. Shapes and text boxes are selected 

from along the left-hand side margin of the map composer window. The figure below illustrates an 

example of a template complete with title block. Templates can be dragged into the print layout 

window from the Browser panel, which will then automatically set the correct page size.  

 

Each item of the template is listed in the Item panel and can be turned on or off and edited. Note 

that the position of the features can be set and adjusted using the “Position and Size” options in 

the item properties dialog box. Each item, e.g. page frame, insert box, logo, etc., has its own item 

properties and these can be varied independently.  
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The image above shows all the items that map up the map frame.  
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The example above is the “Logo” item (diamond image on the layout) and its location is referenced 

to the top left-hand corner of the page as shown in the 3 x 3 box array. It is located 215 mm to the 

right and 152 mm below the top left hand corner of the page, with a width of 8 mm and a height of 

7 mm. 

Each text box has a location and is edited as required in the Label > Main Properties window. The 

image below shows the “Author” field selected and the details can then be added to the existing 

text, or changed as required. If the text boxes require adjustment, use the position and size options 

attached to the item. 

 

Note that these templates may require adjustments for different printers and plotters depending 

on their “print area”. 

The position and size of the inserted map window can be adjusted under the “Map” item properties 

and using the “Position and Size” options. The reference point in the figure below shows the 

measurements from the top LHS of the page. 
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To insert a map of fixed/pre-determined size, in the Print Layout, select the View > Manage 

Guides and set the horizontal and vertical guidelines. The inserted map windows can then be 

adjusted to fit these guidelines. Grids can also be used to align map items. 
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12.3 Layout Manager 

The layout manager shows what layouts are attached to the project. You can have many layouts 

of different sizes and configurations all saved with the project. If you have a set layout where 

you need different themes on maps, you can use the duplicate button to make a copy of the 

layout. Note that you need to “lock” layers in a layout to prevent a ref resh from re-drawing the 

layout display. 

 

12.4 Using Variables to Display Information 

Variables can be used to populate information in text boxes, e.g. the map author’s name, QGIS 

version, or the file path to the Project file. There are various types of variable and they can be 

applied globally, for a specific project or layout.  

Global variables apply to QGIS overall and they can be found in the main menu item Settings > 

Options and the Variable tab. 
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A number of default global variables are added by QGIS. Note that I have added a new variable 

name “author_name” with its value being Grant Boxer. I can then use this variable to add my 

name anywhere on a layout by using the [%@author_name%] statement.  

 

There are similar windows for the Project Properties and Layer Properties.  
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13: MISCELLANEOUS TRICKS AND TIPS 

13.1 Access Databases 

Connecting to an Access database requires some additional steps than required for the open 

source database programs.  

Open the 64-bit ODBC admin window (via the Windows search box) and add another “Access 64-

bit line”, select the database name and location in the User DSN tab – e.g. “LateriteChem”. 
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In the Open Data Source Manager, select the Add Vector option, and type of Database. Connect 

to the database and Add. 
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The next window will display the tables available for import.  

 

If the table has spatial data, e.g. coordinates, then after import, use the Processing Toolbox > 

Algorithms > Vector Creation > Create Points Layer from Table, and select the field for the 

coordinates and the applicable Coordinate Reference System.  

13.2 AutoSaver Plug-In 

The Auto-Saver plug-in will save your project at regular intervals. I have had problems with this 

turned on during digitising and I recommend it is turned off when creating new files.  

13.3 Spatial Bookmarks 

Bookmarks are used to remember the extents of a map window and they are saved with the project 

data. When a bookmark is saved, the bookmark list panel is displayed.  Bookmarks are created 

via View > New Bookmark or via the Browser panel. 

13.4 Colour Ramps 

To add additional colour ramps to the default option use the “Create New Colour Ramp” from the 

drop down box to the right of the Color Ramp selection box,.  The preset colour ramps are shown 

in the “Color Ramp” dialog box and I recommend the Catalog: cpt-city option which will display 

the next dialog box.  

There are many different groups to select from, but I prefer the QGIS tab, and the continuous 

colour bands, e.g. “bgyr”. 



QGIS In Mineral Exploration   

 P a g e  | 158 
 

 

 

 

 



QGIS In Mineral Exploration   

 P a g e  | 159 
 

 

 

New colour ramps can also be imported via the Style Manager dialog box.  

The Centre for Exploration Targeting (CET) in Perth have developed colour ramps that are better 

for visual perception (see this link https://peterkovesi.com/projects/colourmaps/). They are 

available in a QGIS xml format that can be imported via the Style Manager. These styles can then 

be access as favourites. My preference for data grids such as magnetics is to use the CET-R1 

colour ramp. 

https://peterkovesi.com/projects/colourmaps/
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13.5 Colour Selection 

To assist in selecting colours for maps, you can visit the ColorBrewer website 

(http://colorbrewer2.org) where rgb, hex and cymk values of a huge variety of colour options can 

be viewed and selected as required. 

13.6 Data Searching 

When searching large datasets, a number of options can be used. Spatial searches can be done 

in your map window but text searches are best done via the Expression form. 

Highlight the layer in the Layers panel, bring up its attribute table and click on the “Select Features 

Using an Expression” button. 

 

 

 

This will bring up the expression editor window. Click on the central panel to select the field to 

search in, then press “all unique” in the lower right hand side of the dialog box to show all the 

entries in this field. You can filter by entering values into the “Values” window. Double click the 

field name to enter it into the left hand panel. Use the function button to add a function, e.g. “=” 

and then double click on the value to search for in the right hand panel. Hit select to run the query.  

 

http://colorbrewer2.org/
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Go to the attribute table and select the “Move selection to top” of the table. This may take a little 

while in large datasets but it will display the selected record(s) at the top of the table and highlight 

them.  

 

 

To show these on the map, select the “Pan map to selected rows” icon and the map will pan to 

the area of the selected features. 

 

 

13.7 Digitising Toolbar (PlugIn) 

Every tool is activated as soon as the active layer is of an appropriate type and in edit mode. Keep in 
mind that some tools need that the current layer's CRS matches the project CRS. 

As a general rule of thumb your editing layer's CRS and the project's CRS should match. It makes 
life easier. If you need results in a different CRS, transform the layer after you have finished your 
digitizing session. 

All edits can be undone/redone using QGIS' standard undo/redo capabilities. 
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Description of the tools 

Split multi part to single part 

applies to: MultiPoint, MultiLine and MultiPolygon layer 

1. batch mode: The selected multi-part features in the active layer are split into single part and 
added to the layer as new features, keeping the attributes of the original (multi-part) feature. 

2. interactive mode: click on any multi-part feature. The feature will be split into single parts 
which are added to the layer as new features, keeping the attributes of the original (multi-part) 
feature. 

Split off one part and add it as new feature 

applies to: MultiPoint, MultiLine and MultiPolygon layer 

Click on any part of a multi-part feature. The part will be deleted from the original feature and added 
as a new (single-part) feature to the layer keeping the attributes of its parent (multi-part) feature. 

Split features 

applies to: Line, multiLine, polygon and multiPolygon layers 

Works exactly like Split Features tool in QGIS' Advanced Digitizing Toolbar when applied to non-multi 
features. When applied to multi features the user is asked via a dialog (see below) which of the newly 
created geometries (fraction of a part) should become the new feature. The other fraction stays as 
part within the original multi feature. Thus it replaces QGIS' Split Parts, too, which is of limited use, 
because its application results in an invalid geometry if the split-off part is not edited any further. The 
dialog shown when splitting multi-part features has four buttons: 

1. Cancel aborts the current splitting operation and leaves all features untouched.  
2. No to All aborts the splitting of the current feature and leaves it untouched. 
3. No leaves the currently highlighted fraction in the multi-part feature. 
4. Yes accepts the currently highlighted fraction for becoming the new feature. 

Merge selected features 

applies to: any layer with a primary key field, i.e. a database layer 

This works as the Merge selected features button in QGIS Core, except that Core's Merge selected 
features deletes all selected features and then inserts a new feature. DigitizingTools' method offers 
the user to choose which feature to keep by choosing its primary key value. This feature's geometry is 
updated with the combined geometry of all selected features, while all other selected features are 
deleted. This feature will be removed once #13490 is closed and implemented. 

Exchange attributes between selected features 

applies to: any vector layer 

Exchanges the attributes between two selected features of the active layer. Reasoning: when splitting 
features in a layer coming from a database provider the user can thus control which feature is going 
to keep the primary key value (important for related tables). 

Cut with polygon from another layer 

http://hub.qgis.org/issues/13490
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applies to: line and polygon layer (multi or single part) 

Choose another layer whose selected features are used like a cookie cutter on the active layer. 
Everything that falls under the cutter feature(s) is erased. If a selection exists in the active layer only 
selected features are cut. In case a feature would completely disappear, a message is issued to the 
user, asking if this feature should be deleted. 

Clip with polygon from another layer 

applies to: line and polygon layer (multi or single part) 

Choose another layer whose selected feature is used like a cookie cutter on the active layer. 
Everything that falls under this feature will survive, everything outside will be erased. If a selection 
exists in the active layer only selected features will be clipped. 

Fill ring 

applies to: polygon layer (multi or single part) 

Fill rings (islands) in polygons with new features. This tool has two modes: 

1. batch mode: all rings in the selected features are filled with new features. The attribute set for 
all features is identical and can be entered once if form popup after feature creation is not 
suppressed. 

2. interactive mode: click into any the ring. A new feature is snuggled into the ring. 

Fill gap 

applies to: polygon layer (multi or single part) 

Fill gaps between the selected polygons of the active layer with new features. The algorithm has to 
union all selected features first, thus the selection is necessary to speed up the process, especially if 
the layer contains many features. This tool has two modes: 

1. batch mode: all gaps between the selected features are filled with new features. The attribute 
set for all features is identical and can be entered once if form popup after feature creation is 
not suppressed. 

2. interactive mode: click into the gap to be filled. A new feature is snuggled into the gap. 

Fill gap (all visible layers) 

applies to: polygon layer (multi or single part) 

Fill gaps between the polygons of all visible layers with a new feature: click into the gap to be filled. A 
new feature is snuggled into the gap. 

Split selected features with selected line from another layer 

applies to: line and polygon layer (multi or single part) 

Splits all selected features of the active layer with the selected line feature of another layer. The 
splitting creates new features (not multi features). Each new feature resulting from being split retains 
its original attributes. 

Flip line 
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applies to: line layer (multi or single part; does not make too much sense with multi part, though) 

Flip the direction of a line, i.e. reverse the node order within the line. This tool has two modes: 

1. batch mode: all selected lines are flipped. 
2. interactive mode: click any line feature to have it flipped (successful clicking depends on 

layer's snap settings). 

 

13.8 Favourites 

To add a directory as a Favourite for quick access, right click on the “Favourites” item in the 

Browser panel, then add directory. The favourite directory will then make it much quicker to access 

commonly used files. 

13.9 Profile Tool 

This plug-in allows the user to put a line across a grid and obtain a profile along the line.  Note 

there will a new addition to the View menu in version 3.26 where the Elevation data can be viewed 

in profile direct within QGIS. 

13.10 Points to Lines and Polygons 

To create a line or polygon from a list of coordinates, for example an excel spreadshe et with 

tenement corners, use the Processing Toolbox > SAGA > Vector Line Tools > Convert Points to 

Lines and/or Convert Lines to Polygons. 

13.11 QPackage 

The QPackage plug-in allows the user to create a project file with an associated folder holding all 

the relevant layers for that project. Note that this will only copy vector files. 

13.12 Quick Rectangles, Circles, Ellipse Shapes 

The Shape Digitising tool bar allow the creation of vector shapes, e.g. rectangle and circles. 

13.13 Refactor Field 

The Refractor Field algorithm allow the modification of a tables’ attributes. Be careful using this! 
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Note the fields with way too many decimals. These can be fixed using the Processing Toolbox > 

Vector General > Refactor Fields. 

 

Field names, types and other info can be changed in this window. 

13.14 Selecting Drill Holes by Tenement 

To select drill holes in a tenement, simply highlight the drill hole layer in the Layers panel, then in 

the top menu bar choose, select Features by polygon, then right click on the polygon you want to 

use to select the drill holes, the select layer (e.g. tenements layer) will be listed, just select that 

layer and the holes will selected for that tenement. Note this may not worked with layers in different 

projections. 
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The other method that can be used is the Processing Toolbox > Vector Selection > Select by 

Location algorithm. 

 

 

If you hold the "Alt" key while making a selection QGIS, it switches from an "intersects" type 

selection to a "contains" selection mode. (This also works while holding the shift modifier to add 

to a selection, or ctrl to subtract from a selection!).  

13.15 Spatialite Databases 

A Spatialite database is a simple, single file database structure that can hold very large files but 

with the advantage that the data is spatially referenced. The spatial referencing allows the data to 

be quickly displayed when panning across a map. This is very useful for data such as the 250k 

vector data (from GA) for Australia or the large GSWA open file drill hole database. 

The use of Spatialite database files can rapidly increase the speed of accessing large data sets. 

As an example, the entire 1:250 000 Geoscience Australia Australia-wide topographic vector data 

in zipped shapefile format is 1.01 Gb in size (GA file 64058.zip) and comprises many layers 

including road, rivers, etc. This file can be loaded into a Spatialite database file of about 3 Gb, but 

although a large file, the data is spatially indexed, and re-drawing of the data is very fast when 

panning from area to area.  

Another spatialite option is to use the new GeoPackage file format which can store large datasets 

comprising vector, raster and non-spatial data. 
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13.16 Extracting Colour Styling Information from MapInfo Files 

Colour polygon information can be extracted from MapInfo files using an RGB extraction routine 

in the MapInfo-Discover module. 

 

14: USING DRONE MAPPING DATA IN QGIS 

The use of drones is now becoming commonplace for mapping, particularly with the inexpensive 

drones now available on the market. Drone derived orthophoto maps, digital terrain models, digital 

surface models and point clouds can be read directly into QGIS.  

 

An example of an orthophoto created with the DJI Mini 2 and 6 ground control points. 

I have a DJI Mini 2 with which I have been experimenting with lately  to create orthophoto maps 

for various projects and found it particularly useful when documenting mineral exploration  

activities, environmental disturbance and/or construction progress. In my experience I have been 

able to get accuracies of the order of 5 m with the built-in drone GPS and this can be improved 

with ground control points located by handheld gps. Greater accuracies will be achieved if the 

ground control points are accurately surveyed with 10 cm being acheivable. In many cases 2-3 m 

accuracy will be suffice. Oblique aerial views are also very useful to document progress and for 

public relations images. 



QGIS In Mineral Exploration   

 P a g e  | 168 
 

 

Example of digital terrain model (DTM) from drone survey. 

It is important to understand your drone and be a capable drone pilot before trying any drone 

mapping. Note also you will require government accreditation, e.g. via the Civil Aviation and Safety 

Authority (CASA) in Australia, before you can fly your drone. Please check your local regulations. 

 

Example of digital surface model (DSM). 

There are numerous YouTube videos that explain the map making and drone process. I have 

found with my DJI Mini 2, I can fly at 120 m agl (above ground level, maximum allowed) with a 50 

m line spacing and that will allow the creation of an orthophoto with a 4 cm per pixel ground 

resolution and sufficient photo overlap to allow good orthophoto creation . 
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Example of a point cloud for the above examples using CloudCompare program. 

My workflow comprises whether to mark out ground control points, at least 6 to cover a rectangular 

area, if moderate accuracy is required. Ground control points need to be clearly visible from the 

air and I have been trialling 4 x 30 cm square ceramic tiles, two white and two black, to create a 

checkerboard pattern which are clearly visible from 120 m agl.  These tiles will also be resistant to 

the weather and the GCP’s should be useable over a number of years. 

Note that if you have surveyed mining tenements, for example a mining lease boundary, these will 

have been accurately surveyed and as such are useful ground control points.  
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Example of a ground control point using 4 x 30 cm ceramic tiles.  

I use three software applications; DJIFlightPlanner, to create pre-programmed flight missions, the 

Litchi app for my smartphone, and WebODM to carry out the photogrammetry calculations to 

create orthophotos, DTM, DSM and point clouds of the collected data.  None of these are free but 

they are low cost. 

There are a number of flight planning software options available, and these programs create a 

pre-programmed flight so that the drone knows where to fly, how high and other variable like speed 

and camera photo intervals. The output from the flight planning software is transferred to the flight 

controller app – the Litchi app – on your smartphone which will send the flight information to the 

drone. 

Once the photos have been collected, they are checked and then loaded into the photogrammetry 

program WebODM. 

Mission Planning 

To plan your drone survey, create a KML (Google Earth) polygon file in QGIS and import this into 

DJIFlightPlanner. Select your drone camera from the drop-down list on the left and check the 

suggested flight parameters in the right-hand side of the pop-up box. 

I would typically adjust the “Altitude” to my preferred altitude of 120 m (roughly 390 ft) and a 

ground speed of 20 kph, which allows a photo interval 7 seconds to give a suitable photo overlap 

(70%). 

 

 

The flight line direction can then be selected. 
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The flight lines and photo points are then calculated. 

 

These flight lines are then exported using the “Export” to “CSV for Litchi” option. I would then 

create a time-based flight and use the split the flight plan into 4 flights per plan.  
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The reason for multiple plans is that I know the Mini 2 batteries have an endurance (flight time) of 

about 20 minutes, so I design each plan to have a flight time of around 15 minute to allow for 

drone return to home and any unforeseen headwinds. The battery will be replaced after each flight 

and with 6 batteries, this allows me to fly six flight plans before I need to recharge my drone 

batteries. 

Creating the Flight Plan 

The output from the DJIFlight Planner, the csv file, is imported using the Litchi Mission Hub web 

portal (flylitchi.com/hub) and the Mission > Import option. 

Within the Litchi Mission Hub, you can fine tune what happens at each waypoint, e.g. the height 

and photo interval. The return to home (RTH) option is set in the Litchi app on you r smartphone 

so at the end of each flight plan, the drone returns to home. Note this window displays the length 

of the flight plan and the flight time. 

 

https://flylitchi.com/hub


QGIS In Mineral Exploration   

 P a g e  | 173 
 

When all the details are correct this is saved to the mission hub and can be downloaded to your 

smartphone when you next open up the Litchi app (making sure you do this while you have an 

internet connection). The background Google Earth image will be cached in your phone if you 

open up each flight plan while you have an internet connection. 

Flying Your Mission 

Before you fly, make sure all your batteries are charged and the weather is suitable. Check for 

any helicopter activity in the area before you fly. After take-off, check all your aircraft settings are 

correct, such as photo type (single, timed image, 3000x4000 aspect for DJI Mini 2). Fly your 

missions. 

Processing the Images 

After collecting the photos and downloading them to your computer, check the photos and remove 

those that are not necessary, like those collected during ferry trips etc. Identify the images with 

the ground control points (GCP) so they can be used in the creation of the ground control point 

file. GCP’s will usually be identified in about 4 images for each GCP and this is required for 

WebODM to be able to rectify the orthophoto. 

The orthophoto above was created using WebODM from a collection of 266 images and a ground 

control point file. Processing on my laptop (64 Gb RAM, Core i7 processor) took about 6 hours, 

so I usually run it overnight. A desktop PC with a large amounts of RAM and disk space, plus 

multiple cores may make this processing a little quicker.  

The default setting with WebODM will create an orthophoto, a digital surface model (dsm), a digital 

terrain model (dtm, ground level) and a point cloud. 
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37.1—Sedimentary-rock lithologic patterns

37—LITHOLOGIC PATTERNS
[Lithologic patterns are usually reserved for use on stratigraphic columns, sections, or charts]
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601
Gravel or

conglomerate
(1st option)

602
Gravel or

conglomerate
(2nd option)

603
Crossbedded gravel

or conglomerate

605
Breccia (1st option)

606
Breccia (2nd option)

607
Massive sand or

sandstone

608
Bedded sand or

sandstone

609
Crossbedded sand

or sandstone
(1st option)

610
Crossbedded sand

or sandstone
(2nd option)

611
Ripple-bedded sand

or sandstone

612
Argillaceous or

shaly sandstone

613
Calcareous
sandstone

614
Dolomitic
sandstone

616
Silt, siltstone,
or shaly silt

617
Calcareous

siltstone

618
Dolomitic
siltstone

619
Sandy or silty

shale

620
Clay or clay

shale

621
Cherty shale

622
Dolomitic shale

623
Calcareous shale

or marl

624
Carbonaceous

shale

625
Oil shale

626
Chalk

627
Limestone

628
Clastic

limestone

629
Fossiliferous clastic

limestone

630
Nodular or irregularly

bedded limestone

631
Limestone, irregular
(burrow?) fillings of

saccharoidal dolomite

632
Crossbedded

limestone

633
Cherty crossbedded

limestone

634
Cherty and sandy

crossbedded
clastic limestone

635
Oolitic

limestone

636
Sandy limestone

637
Silty limestone

638
Argillaceous or
shaly limestone

639
Cherty limestone

(1st option)

640
Cherty limestone
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641
Dolomitic limestone,
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642
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643
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644
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or dolomite
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37—LITHOLOGIC PATTERNS (continued)
[Lithologic patterns are usually reserved for use on stratigraphic columns, sections, or charts]
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652
Fossiliferous rock

653
Diatomaceous

rock

654
Subgraywacke

655
Crossbedded
subgraywacke

656
Ripple-bedded
subgraywacke

657
Peat

658
Coal

645
Sandy dolostone

or dolomite

646
Silty dolostone

or dolomite

647
Argillaceous or
shaly dolostone

or dolomite

648
Cherty dolostone

or dolomite

649
Bedded chert
(1st option)

650
Bedded chert
(2nd option)

651
Fossiliferous
bedded chert

659
Bony coal or
impure coal

660
Underclay

661
Flint clay

662
Bentonite

663
Glauconite

664
Limonite

665
Siderite

666
Phosphatic-nodular

rock

667
Gypsum

668
Salt

669
Interbedded

sandstone and
siltstone

670
Interbedded

sandstone and
shale

671
Interbedded ripple-
bedded sandstone

and shale

672
Interbedded shale
and silty limestone
(shale dominant)

680
Interbedded

limestone and
calcareous shale

681
Till or diamicton

(1st option)

682
Till or diamicton

(2nd option)

683
Till or diamicton

(3rd option)

684
Loess (1st option)

685
Loess (2nd option)

686
Loess (3rd option)

673
Interbedded shale

and limestone
(shale dominant)

(1st option)

674
Interbedded shale

and limestone
(shale dominant)

(2nd option)

675
Interbedded calc-
areous shale and
limestone (shale

dominant)

676
Interbedded

silty limestone
and shale

677
Interbedded

limestone and
shale (1st option)

678
Interbedded

limestone and
shale (2nd option)

679
Interbedded

limestone and shale
(limestone dominant)
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37—LITHOLOGIC PATTERNS (continued)
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717
Basaltic flows

718
Granite (1st option)

719
Granite (2nd option)

720
Banded

igneous rock

721
Igneous rock
(1st option)

723
Igneous rock
(3rd option)

724
Igneous rock
(4th option)

725
Igneous rock
(5th option)

726
Igneous rock
(6th option)
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Igneous rock
(7th option)

728
Igneous rock
(8th option)
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Igneous rock
(2nd option)

711
Tuffaceous rock
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Crystal tuff

713
Devitrified
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Volcanic breccia
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715
Volcanic breccia
or agglomerate

716
Zeolitic rock

729
Porphyritic rock

(1st option)
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Porphyritic rock

(2nd option)
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Vitrophyre
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Quartz

733
Ore

707
Schist and gneiss

708
Gneiss

709
Contorted gneiss
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Soapstone, talc,
or serpentinite

701
Metamorphism
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Quartzite
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Schistose or
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Schist
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Contorted schist
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Pattern is in front. One bounding box (having Fill and Stroke set to 'None') is in back

K, black; C, cyan; M, magenta; DO, dropout; R, red; B, brown

White background is transparent (underlying map-unit color will be visible)

Black background represents underlying map-unit color. If white pattern is used "as is," it will
knock out the underlying map-unit color; if pattern is changed to one of the CMYK values in
the underlying map-unit color, it will knock out the other CMYK value(s) in map-unit color

Overprint patterns have white background

Dropout patterns have black background

Abbreviations used in pattern numbers:

Pattern is in front. Two bounding boxes are in back: box directly beneath pattern has Fill set
to 100% black and Stroke set to 'None'; box to rear has both Fill and Stroke set to 'None'

This diagram provides some basic information on how to use the new Pattern Chart, which is enclosed in the sleeve on the inside back cover of 
this standard volume. For more specific information on the use of patterns (and color) on geologic maps, see Section 5, entitled "Guidelines for 
Map Color and Pattern Selection," in the accompanying introductory text.
Most patterns on this new chart were designed (in Adobe Illustrator 8.0.1) to closely replicate patterns in the informal "Technical Cartographic 
Standards" volume (U.S. Geological Survey, ca. 1975). In some cases, however, lineweights of pattern elements had to be increased to facilitate 
higher resolution (1800 dpi) digital output; therefore, some patterns may not plot or print correctly if output at lower resolutions.
Each pattern has been assigned a new pattern number (see below each box). In addition, each pattern now has associated with it a generic 
look-up table number that can be used to access a pattern if it has been incorporated into a patternset.

IGNEOUS PATTERNS (Series 300)

301-M 301-DO301-C301-K

302-K 302-C

304-C

305-K

306-K 306-C 306-M 306-DO

305-C 305-M 305-DO

304-M 304-DO304-K

302-M 302-DO 

303-K 303-C 303-M 303-DO

301 302 303 304

305 306 307 308

309 310 311 312

313 314 315 316

317 318 319 320

321 322 323 324

Pattern number
shown below box

Generic lookup-table number
shown in upper left-hand

corner of box (can be used
to access a particular

pattern from a patternset)

http://pubs.usgs.gov/tm/2006/11A02/ai8/FGDCgeostdTM11A2_A-38-01ai8.eps
http://pubs.usgs.gov/tm/2006/11A02/cs2/FGDCgeostdTM11A2_A-38-01cs2.eps
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